installing programs

Marc Fromm Marc.Fromm at
Wed Nov 7 09:28:20 PST 2007

I am new to the linux-type OS environment. For about a week now I have
tried to do a task which I first thought would be simple-install a
program like firefox.


I did "sudo pkg_add -r firefox" as explained in chapter 4 of the
handbook and received the message:

pkg_add: package 'firefox-,1' or its older version already


I then tried to uninstall firefox like this:

sudo pkg_delete -d -f firefox-,1

It appeard to uninstall.


I next did "sudo pkg_add -r firefox" again and it did this:

> Fetching

> Done.

> ===> Building Chrome's registry...


> ======================================================================


> SMB issues:

> Network group, machine, and share browsing does not work correctly.



> Only sftp access using public key authentication works.  To easily 

> setup public key authentication to "remote_host":


> ssh-keygen -t dsa

> cat ~/.ssh/ | ssh remote_host "cat >> .ssh/authorized_keys"


> The SSH sever on remote_host must allow pub key authentication.


Firefox now does not work at all and if I rerun the pkg_add command it
states firefox- is still installed.

Isn't the latest


I tried to instructions at firefox and they did not work:





Marc Fromm
Information Technology Specialist II
Financial Aid Department
Western Washington University
Phone: 360-650-3351
Fax:   360-788-0251


More information about the freebsd-questions mailing list