Marvell 88SE61xx (was: Re: Intel D975XBX2 - BTX halted)

Alexander Anderson a.anderson at
Sat Mar 31 16:34:39 UTC 2007

Thu, Mar 29, 2007 at 10:43:51 PM, Alexander Anderson wrote:
> Hello.
> I'm installing FreeBSD 6.2-RELEASE on a brand new system with Intel
> D975XBX2 board. It seems that FreeBSD does not support the onboard Marvell
> 88SE6145 SATA controller. Could someone confirm this?
> At first, when I tried to boot the installation CD, the loader hung very
> early in the process with the message "BTX halted". But when I went to the
> BIOS and disabled "Secondary SATA controller" (in Advanced, Peripheral
> Configuration), the CD booted and the install began alright.


> Now that I figured out what was causing the "BTX halted" error, I'm going
> to complete the installation, and then try to enable the Marvell
> controller back. Let's see if that works.

No one seems to have replied ...but I'll draw the summary, anyway.

The installation has completed successfully with Marvell 88SE6145 SATA
RAID controller disabled. When I go to BIOS and enable it back, the system
still boots, but dmesg shows no sign of Marvell's presence.

I'm still not sure if the controller is just not configured correctly or
if it is not supported under FreeBSD at all, however, I'm leaning towards
the latter.

Maybe I'll try asking in freebsd-hackers.

Oh well, I guess I'll be looking for the second RAID controller on a PCI-X

More information about the freebsd-questions mailing list