fsck fails on 6T system

Dan D Niles dan at more.net
Thu Mar 29 02:47:04 UTC 2007

On Wed, 2007-03-28 at 20:21 -0500, Josh Paetzel wrote:
> Dan D Niles wrote:
> > I am trying to fsck a 6T filesystem on a server that crashed.  I'm
> > running FreeBSD 6.2-p3.
> > 
> > # fsck -t ufs -y /dev/da0
> > fsck_ufs: cannot alloc 1993797728 bytes for inoinfo
> > 
> > I also tried:
> > 
> > # fsck -t ufs -f -p /dev/da0
> > /dev/da0: UNKNOWN FILE TYPE I=11895232
> >
> > I built a custom kernel with MAXDSIZ and DFLDSIZ just under 3G, and got
> > the same results.  It was at about 430M in use when it crashed, so the
> > total would be 2332 M which is less that the size allowed (reported by
> > limits).
> > 
> RAM...lots and lots of RAM.  Start with about 8 gigs and give it a 
> try.

The machine has 3G of RAM.  But as I said, it should only be using 2.3G
when it stops.  It has 3G of space so adding more RAM wouldn't help.  It
does not appear that it will go past 2G even though I increased the
process limits to near 3G.

BTW, if MAXDSIZ plus MAXSSIZ is greater than the size of real memory the
machine won't boot. I tried it.  Also, the max memory FreeBSD can use is
about 3.5G unless you use the experimental PAE kernel.

Any other ideas on how to get fsck to work on a 6T filesystem?



More information about the freebsd-questions mailing list