Time changed back to old daylight savings

Don O'Neil lists at lizardhill.com
Wed Mar 28 18:51:20 UTC 2007

I don't have the port tree installed, so you are correct that I did not
update them first... I installed JUST the zoneinfo port, which according to:


"the misc/zoneinfo port can be installed to update the /usr/share/zoneinfo
files, followed by running tzsetup(8) to update /etc/localtime"

So why wouldn't installing this port fix the problem like advertised? I
shouldn't even have the problem to begin with... When the time change
happened a few weeks ago my system updated correctly, but since then I've
built a new kernel (the only thing I've done) and now it's not right.

-----Original Message-----
From: owner-freebsd-questions at freebsd.org
[mailto:owner-freebsd-questions at freebsd.org] On Behalf Of Lowell Gilbert
Sent: Wednesday, March 28, 2007 11:08 AM
To: Don O'Neil
Cc: freebsd-questions at freebsd.org
Subject: Re: Time changed back to old daylight savings

"Don O'Neil" <lists at lizardhill.com> writes:

> Ok,  Thanks to Paul who sent me the previous tzdata file I was able to 
> download the port and install it... However that didn't solve the problem!
> Here's my output from the make/make install:
> make install
> ===>  Installing for zoneinfo-2007.c
> ===>   Generating temporary packing list
> ===>  Checking if misc/zoneinfo already installed /bin/mkdir -p 
> /usr/share/zoneinfo /bin/cp -R -p /home/don/zoneinfo/work/zoneinfo/ 
> /usr/share/zoneinfo install  -o root -g wheel -m 444 
> /home/don/zoneinfo/work/zone.tab
> /usr/share/zon                         einfo
> Now run tzsetup(8) again to install the right file to /etc/localtime.
> ===>   Registering installation for zoneinfo-2007.c
> kermit# date
> Wed Mar 28 09:37:23 PDT 2007
> kermit# /usr/sbin/ntpdate -v -b 0.us.pool.ntp.org
> 28 Mar 09:37:27 ntpdate[52308]: ntpdate 4.2.0-a Mon Aug  7 17:44:27 
> UTC 2006
> (1)
> 28 Mar 09:37:29 ntpdate[52308]: step time server 
> offset
> 3583.019
> I ran tzsetup and then ran ntpdate.
> It was 10:37 when I ran ntpdate.... Not 9:37.
> This is strange... Any more ideas?

You didn't update your ports tree before installing the port, I'll bet.
That was an essential part of the advice that Kevin Kinsey gave you.  
freebsd-questions at freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscribe at freebsd.org"

More information about the freebsd-questions mailing list