Fwd: pause before "Trying to mount root from ufs:"

Vlad GURDIGA gurdiga at gmail.com
Tue Mar 20 07:37:15 UTC 2007


Very glad to be back with a a solution to my earlier problem: the key
was the SCSI_DELAY option in kernel: I've change it from the default
5000 to 500 (I guess milliseconds) and now th delay before "Trying to
mount root from ufs" is gone.

The way to solution was not very smart but simple, and I'm going to
tell it because it may help with other troubles too: I tried to boot
with a 6.0-RELEASE but the delay was still there, then I tried to boot
from a 5.4-RELEASE boot CD and it went smooth! No delay! A diff
between output of sysctl -a on both versions revealed a possible
difference: the sysctl kern.cam.scsi_delay variable is not present on
5.4-RELEASE (GENERIC) at all. There is also a chapter in handbook
about this: http://graphics.itb.ac.id/wnugroho/freebsd/handbook/configtuning-disk.html SCSI_DELAY (kern.cam.scsi_delay).

Have a nice day!

---------- Forwarded message ----------
From: Vlad GURDIGA <gurdiga at gmail.com>
Date: 15-Mar-2007 10:20
Subject: pause before "Trying to mount root from ufs:"
To: freebsd-questions at freebsd.org


My motherboard Intel D955XBK died these day, I took it to service
center and they gave me a new one of another model: DP965LT.
On my home computer I have dual boot with Windows XP and FreeBSD
6.2-STABLE. I've expected Windows XP not to boot at all after the
change, but fortunately it successfully came up, found all new
component and everything went smooth. What I did not expect at all is
that FreeBSD showed some problems: there is a short pause on boot
before (I've measured about 4 seconds) before "SMP: AP CPU #1
Launched!", and a long one (I've measured about 90 seconds!!!) between
this message and "Trying to mount root from ufs:/dev/ad8s2a".
Last night (14.03.2007) I've updated mys source tree (6.2-STABLE) an
rebuilt the work and kernel hoping for salvation to come, but it did
not. Rebuilt SMP-GENERIC but it did not help either.
Another (bad) change that came with the motherboard change is that
Xorg is hanging on start without any message. If I try to get back to
console with Alt-Ctrl-FN, it beeps. Alt-Ctrl-Backspace does not work
either. Keyboard is working: NumLock responds and fortunately
Alt-Ctrl-Del works fine too, being the only way out of Xorg's hang.

With the exception of motherboard nothing changed in hardware.

What could be the cause?

Here is the dmesg output.

-------- dmesg output start --------
Copyright (c) 1992-2007 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 6.2-STABLE #0: Wed Mar 14 23:33:20 EET 2007
    root at kpax:/usr/src/sys/i386/compile/kpax.smp
WARNING: MPSAFE network stack disabled, expect reduced performance.
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Pentium(R) D CPU 2.80GHz (2802.82-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0xf44  Stepping = 4
  AMD Features=0x20100000<NX,LM>
  Cores per package: 2
real memory  = 1055305728 (1006 MB)
avail memory = 1019219968 (972 MB)
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1
ioapic0: Changing APIC ID to 2
ioapic0 <Version 2.0> irqs 0-23 on motherboard
kbd1 at kbdmux0
ath_hal: (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
acpi0: <INTEL DP965LT> on motherboard
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
cpu0: <ACPI CPU> on acpi0
p4tcc0: <CPU Frequency Thermal Control> on cpu0
cpu1: <ACPI CPU> on acpi0
p4tcc1: <CPU Frequency Thermal Control> on cpu1
acpi_button0: <Sleep Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <PCI-PCI bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
drm0: <ATI Radeon RV370 X550> port 0x2000-0x20ff mem
0x40000000-0x4fffffff,0x50210000-0x5021ffff irq 16 at device 0.0 on
info: [drm] Initialized radeon 1.25.0 20060524
pci1: <display> at device 0.1 (no driver attached)
pci0: <simple comms> at device 3.0 (no driver attached)
em0: <Intel(R) PRO/1000 Network Connection Version - 6.2.9> port
0x30c0-0x30df mem 0x50300000-0x5031ffff,0x50324000-0x50324fff irq 20
at device 25.0 on pci0
em0: Ethernet address: 00:19:d1:09:de:de
uhci0: <UHCI (generic) USB controller> port 0x30a0-0x30bf irq 16 at
device 26.0 on pci0
usb0: <UHCI (generic) USB controller> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <UHCI (generic) USB controller> port 0x3080-0x309f irq 21 at
device 26.1 on pci0
usb1: <UHCI (generic) USB controller> on uhci1
usb1: USB revision 1.0
uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
ehci0: <EHCI (generic) USB 2.0 controller> mem 0x50325400-0x503257ff
irq 18 at device 26.7 on pci0
usb2: EHCI version 1.0
usb2: companion controllers, 2 ports each: usb0 usb1
usb2: <EHCI (generic) USB 2.0 controller> on ehci0
usb2: USB revision 2.0
uhub2: Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub2: 4 ports with 4 removable, self powered
pci0: <multimedia> at device 27.0 (no driver attached)
pcib2: <ACPI PCI-PCI bridge> at device 28.0 on pci0
pci2: <ACPI PCI bus> on pcib2
pcib3: <ACPI PCI-PCI bridge> at device 28.1 on pci0
pci3: <ACPI PCI bus> on pcib3
atapci0: <GENERIC ATA controller> port
mem 0x50100000-0x501001ff irq 17 at device 0.0 on pci3
ata2: <ATA channel 0> on atapci0
ata3: <ATA channel 1> on atapci0
pcib4: <ACPI PCI-PCI bridge> at device 28.2 on pci0
pci4: <ACPI PCI bus> on pcib4
pcib5: <ACPI PCI-PCI bridge> at device 28.3 on pci0
pci5: <ACPI PCI bus> on pcib5
pcib6: <ACPI PCI-PCI bridge> at device 28.4 on pci0
pci6: <ACPI PCI bus> on pcib6
uhci2: <UHCI (generic) USB controller> port 0x3060-0x307f irq 23 at
device 29.0 on pci0
usb3: <UHCI (generic) USB controller> on uhci2
usb3: USB revision 1.0
uhub3: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub3: 2 ports with 2 removable, self powered
uhci3: <UHCI (generic) USB controller> port 0x3040-0x305f irq 19 at
device 29.1 on pci0
usb4: <UHCI (generic) USB controller> on uhci3
usb4: USB revision 1.0
uhub4: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub4: 2 ports with 2 removable, self powered
uhci4: <UHCI (generic) USB controller> port 0x3020-0x303f irq 18 at
device 29.2 on pci0
usb5: <UHCI (generic) USB controller> on uhci4
usb5: USB revision 1.0
uhub5: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub5: 2 ports with 2 removable, self powered
ehci1: <EHCI (generic) USB 2.0 controller> mem 0x50325000-0x503253ff
irq 23 at device 29.7 on pci0
usb6: EHCI version 1.0
usb6: companion controllers, 2 ports each: usb3 usb4 usb5
usb6: <EHCI (generic) USB 2.0 controller> on ehci1
usb6: USB revision 2.0
uhub6: Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub6: 6 ports with 6 removable, self powered
pcib7: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci7: <ACPI PCI bus> on pcib7
fwohci0: <Texas Instruments TSB43AB22/A> mem
0x50004000-0x500047ff,0x50000000-0x50003fff irq 19 at device 3.0 on
fwohci0: [GIANT-LOCKED]
fwohci0: OHCI version 1.10 (ROM=0)
fwohci0: No. of Isochronous channels is 4.
fwohci0: EUI64 00:90:27:00:01:d9:79:fe
fwohci0: Phy 1394a available S400, 2 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 02:90:27:d9:79:fe
fwe0: Ethernet address: 02:90:27:d9:79:fe
sbp0: <SBP-2/SCSI over FireWire> on firewire0
fwohci0: Initiate bus reset
fwohci0: node_id=0xc800ffc0, gen=1, CYCLEMASTER mode
firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
firewire0: bus manager 0 (me)
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci1: <Intel ICH8 SATA300 controller> port
irq 19 at device 31.2 on pci0
ata4: <ATA channel 0> on atapci1
ata5: <ATA channel 1> on atapci1
pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
atapci2: <Intel ICH8 SATA300 controller> port
irq 19 at device 31.5 on pci0
ata6: <ATA channel 0> on atapci2
ata7: <ATA channel 1> on atapci2
fdc0: <floppy drive controller> port 0x3f0-0x3f5,0x3f0 irq 6 drq 2 on acpi0
fdc0: [FAST]
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
ppc0: <ECP parallel printer port> port 0x378-0x37f,0x778-0x77f irq 7 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/8 bytes threshold
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse, device ID 3
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
sio0: type 16550A
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem
0xc0000-0xcffff,0xd0000-0xd0fff,0xd1000-0xd1fff on isa0
ata0 at port 0x1f0-0x1f7,0x3f6 irq 14 on isa0
ata1 at port 0x170-0x177,0x376 irq 15 on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounters tick every 1.000 msec
IPsec: Initialized Security Association Processing.
ad8: 152627MB <Seagate ST3160812AS 3.AAD> at ata4-master SATA150
****** here are about 4 seconds of pause ******
SMP: AP CPU #1 Launched!
****** here are about 90 seconds of pause ******
Trying to mount root from ufs:/dev/ad8s2a
-------- dmesg output end --------

-------- loader.conf begin --------
autoboot_delay="-1"             # Delay in seconds before autobooting,
                                # set to -1 if you don't want user to be
                                # allowed to interrupt autoboot process and
                                # escape to the loader prompt
beastie_disable="YES"           # Turn the beastie boot menu on and off
sound_load="YES"                # Digital sound subsystem
-------- loader.conf end --------

More information about the freebsd-questions mailing list