safe0 and kernel panic

Rajkumar S rajkumars at
Tue Mar 20 06:08:07 UTC 2007

On 3/19/07, Lowell Gilbert <freebsd-questions-local at> wrote:

Thanks a lot for your reply.

> "Rajkumar S" <rajkumars at> writes:
> > I am trying to install SafeNet 1141 support in one of the freebsd
> > boxes here.
> You do have one of those cards installed, I assume?

Yes, it's not a card, but an on board chip.

> Have you tried booting a GENERIC kernel and loading the kernel module
> for the safenet support?

Yes, the message I get is

safe0 mem 0xf6120000-0xf6121fff irq 22 at device 10.0 on pci0
safe0: cannot allocate DMA tag
device_attach: safe0 attach returned 6

but the machine remains stable, with no panic. But I still get the
"cannot allocate DMA tag" error that I got when the safenet is
compiled in.

I am not sure if this is normal and I can put the machine live.

> If that doesn't give you a clue, you will need to try kernel
> debugging, as described in the Handbook.

I am trying in that direction also, at least to understand why I am
getting the panic and file a meaning full PR.


More information about the freebsd-questions mailing list