Strange freeze on -STABLE

Deniss Lee deniss.lee at
Fri Mar 16 00:21:08 UTC 2007

Nothing really has changed to my box (no new software, configuration
issues). I just like
rebuilding world/kernel to the latest  -STABLE at least once in week. And
about two weeks
ago I started getting strange freezes. Since then I've tried doing anything
to get away from
those stupid freezes, but nothing helps.

On random time periods my box freezes, but not like the usual way when I
can't do anything.
It drops all network connections (this box is also router), so I can't
connect with SSH anymore
or use Internet through it. It mystical freezes everything else - if I had
opened some xterms (x11
also on this box) then can write some command (for example "ls") - it may or
may not be
executed, but what's strange - after execution it doesn't return to shell,
it even doesn't react on
^C, ^Z or anything at all. Some applications I can close, some I cant and
they just ignore my
attempts. Sometimes I can even ctrl+alt+backspace (it gets executed after
some while),
sometimes I can't. Same with alt+ctrl+f1-f9 - it may work, it may not work.

Only thing I can do is press "power button", but then (again - sometimes) I
"acpi: suspend request ignored (not ready yet)".

Then I just press it for 5 seconds and it powers off. After reboot fsck &

It's just driving my crazy.

But what's interesting - music keeps playing (line-in). Both pf
(firewall/routing) and sound card
is loaded as modules, music keeps playing, but network is unresponsive. And
this box usually
freezes when I'm asleep or when I'm not physically using it (ssh only).

I'm really desperate.
I've tried reinstalling from scratch, rebuilding world, using even GENERIC,
but nothing helps.

I'm using lastest FreeBSD 6.2-STABLE (recompiled even yesterday, but got
crash again).
Box is AMD Sempron.

Please - really - any suggestions? I've run FreeBSD for years but I don't
know what to do now
with this situation.

More information about the freebsd-questions mailing list