AW: FreeBSD 2.2.9 / Installation problem

Nino Ivanov niivanov at
Thu Mar 15 19:43:38 UTC 2007

Dear Chistian, Dear Kris,

I also think the RAM will not be the issue, as it is a text-only install,
and indeed, I am not planning to "get fancy". I completely don't need X.
Midnight Commander is perfectly fine as a working environment. 4.11 seemed

But I am having a different problem right now, which I am still researching:
It does not recognize the device from where to mount root correctly. I mean
the following: When I put FreeBSD into the Compaq for installation, the
harddrive is ad4 or ad8. But in the system where I want to run it, the HP
Omnibook, it is ad0.

Now, when I start it back in the HP Omnibook, it says that swap is not
configured correctly on ad8s-something. Which is true, it should look for it
on ad0... I have only once been able till now to mount root. (And this is my
basis for assuming that even 4.11 CAN potentially run.) I said as command
ufs:/dev/ad0 when it asked me where to mount root from. This worked,
however, e.g. ufs:/dev/ad0s1 did not work. I am thinking that I might have
made a mistake, and should have said ad0s1a.

Yet, the principal new problem persists: FreeBSD does not realize that it
should now look at ad0 instead of ad4 or ad8. (However, in the booting
process, it correctly "sees" ad0 as having 325 MB etc.) Is there a way to
solve this?

If this really works I think I'll write a step-by-step guide...

I really appreciate your help in this matter - thank you a lot!

-----Ursprüngliche Nachricht-----
Von: Kris Kennaway [mailto:kris at] 
Gesendet: Donnerstag, 15. März 2007 19:13
An: Christian Walther
Cc: Nino Ivanov; freebsd-questions at
Betreff: Re: FreeBSD 2.2.9 / Installation problem

On Thu, Mar 15, 2007 at 12:28:12PM +0100, Christian Walther wrote:
> On 15/03/07, Nino Ivanov <niivanov at> wrote:
> >Dear Sir or Madam,
> >
> [...]
> >
> >The target machine is a HP Omnibook 600c laptop with 8MB RAM, a 486 DX4
> >processor, 300 MB disk space. No CD drive. No network available. External
> >floppy drive without DMA. (I tried NetBSD, but because of the lack of DMA

> >it
> >did not work properly.) The functioning of the floppy drive is critical,
> >being the machine's only practical means of communicating with the outer
> >world. Due to cost and time considerations, no upgrades are possible. If 
> >the
> >target machine is not suitable for an installation of FreeBSD, please let

> >me
> >know so I stop further attempts.
> I guess you're without luck in this case. AFAIK FreeBSD needs at least
> 64 MB RAM to work happily. I tried installing it on an P1/133MHz
> Laptop with 16MB RAM, and it freezes after a few minutes. And it's
> dead slow.

Well it is only true of more modern versions that they do not function
well on systems with e.g. 8MB.  FreeBSD 2.x was happy with as little
as 4MB.


More information about the freebsd-questions mailing list