limitiation on memory allocation

Dima Sorkin dima.sorkin at
Mon Mar 12 19:02:50 UTC 2007

 Something is probably wrong.
kern.dfldsiz on my machine does not influence.
I.e. after booting I run
$ limits
and it shows me the old 500M.

Now, a point about 'maxdsiz'= 3.0-3.5G instead of 4G - this one I must check.
I tried 3.9G   :)


On 3/12/07, Chuck Swiger wrote:

> It is certainly possible to configure FreeBSD to allow a single
> process to access more memory than is phyiscally installed.  For
> example, I have a machine with 512MB of RAM, and set:
>    kern.dfldsiz="1G"
> /boot/loader.conf, and this works just fine.  Admittedly, when
> a process does exceed 512MB in dsize, the system starts swapping
> quite a bit, but that's how virtual memory works.
> However, you cannot set maxdsiz greater than 4GB [1] if you are
> running a 32-bit version of FreeBSD.  Enabling PAE will let the
> kernel access more than 4GB of physical RAM, but nothing is going to
> let a 32-bit system give more than 4 GB [1] to a single process...if
> you want to do that, then you'll need to switch to running a 64-bit
> version of FreeBSD.
> --
> -Chuck
> [1]: Well, 3.5GB or 3GB, actually...due to the top portion of address
> space being occupied by PCI device space and the kernel.

More information about the freebsd-questions mailing list