No matter what I try I can't get Nvidia 3d acceleration to work. Please help!

hxc at hxc at
Mon Mar 12 08:39:08 UTC 2007

I am trying for several days now to get 3d acceleration working on 
FreebSD for my XFX 7800 GS. But nothing what I've tried worked :-( . 
Below is a collection of useful information I've gathered thus far. Who 
can help me?
# sysctl hw.nvidia.agp.status*
hw.nvidia.agp.status.status: disabled
hw.nvidia.agp.status.driver: n/a (unused)
hw.nvidia.agp.status.rate: n/a (disabled)
hw.nvidia.agp.status.fw: n/a (disabled)
hw.nvidia.agp.status.sba: n/a (disabled)

*# glxinfo | fgrep direct*
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Error: unable to open display (null)

*# cat /var/log/Xorg.0.log | grep nvidia*
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/
(II) Module nvidia: vendor="NVIDIA Corporation"

*# cat /var/log/Xorg.0.log | grep NVIDIA*
(II) Module glx: vendor="NVIDIA Corporation"
(II) Module nvidia: vendor="NVIDIA Corporation"
(II) NVIDIA dlloader X Driver  1.0-9746  Tue Dec 19 13:23:45 PST 2006
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(--) Chipset NVIDIA GPU found
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NvAGP" "1"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): Use of NVIDIA internal AGP requested
(II) NVIDIA(0): NVIDIA GPU GeForce 7800 GS at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 262144 kBytes
(--) NVIDIA(0): VideoBIOS:
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 7800 GS at PCI:1:0:0:
(--) NVIDIA(0):     PHILIPS 109S4 (CRT-0)
(--) NVIDIA(0):     NVIDIA TV Encoder (TV-0)
(--) NVIDIA(0): PHILIPS 109S4 (CRT-0): 400.0 MHz maximum pixel clock
(--) NVIDIA(0): NVIDIA TV Encoder (TV-0): 400.0 MHz maximum pixel clock
(--) NVIDIA(0): TV encoder: NVIDIA
(II) NVIDIA(0): Assigned Display Device: CRT-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "1280x1024"
(II) NVIDIA(0): Virtual screen size determined to be 1280 x 1024
(--) NVIDIA(0): DPI set to (90, 96); computed from "UseEdidDpi" X config
(--) NVIDIA(0):     option
(II) NVIDIA(0): Setting mode "1280x1024"
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) NVIDIA(0): DPMS enabled

*# dmesg | grep nvidia*
nvidia0: <GeForce 7800 GS> mem 
0xfb000000-0xfbffffff,0xe0000000-0xefffffff,0xfa000000-0xfaffffff irq 16 
at device 0.0 on pci1
nvidia0: [GIANT-LOCKED]

*# tail /boot/device.hints*

*# cat  /boot/loader.conf*

Asus A8V deluxe
Chipset    VIA K8T800 Pro
North bridge    VIA K8T800 Pro
South bridge    VIA VT8237

*# cat /etc/X11/xorg.conf*
Section "ServerLayout"
        Identifier     " Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"

Section "Files"
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        ModulePath   "/usr/X11R6/lib/modules"
        FontPath     "/usr/X11R6/lib/X11/fonts/misc/"
        FontPath     "/usr/X11R6/lib/X11/fonts/TTF/"
        FontPath     "/usr/X11R6/lib/X11/fonts/Type1/"
        FontPath     "/usr/X11R6/lib/X11/fonts/CID/"
        FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/"
        FontPath     "/usr/X11R6/lib/X11/fonts/100dpi/"

Section "Module"
        Load  "dbe"
#       Load  "dri"
        Load  "extmod"
        Load  "glx"
        Load  "record"
        Load  "xtrap"
        Load  "freetype"
        Load  "type1"

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/sysmouse"
        Option      "ZAxisMapping" "4 5 6 7"

Section "Monitor"
        #DisplaySize      360   270     # mm
        Identifier   "Monitor0"
        VendorName   "PHL"
        ModelName    "PHILIPS 109S4"
 ### Comment all HorizSync and VertSync values to use DDC:
        HorizSync    30.0 - 92.0
        VertRefresh  50.0 - 160.0
        Option      "DPMS"

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"                  # [<bool>]
        #Option     "HWcursor"                  # [<bool>]
        #Option     "NoAccel"                   # [<bool>]
        #Option     "ShadowFB"                  # [<bool>]
        #Option     "UseFBDev"                  # [<bool>]
        #Option     "Rotate"                    # [<str>]
        #Option     "VideoKey"                  # <i>
        #Option     "FlatPanel"                 # [<bool>]
        #Option     "FPDither"                  # [<bool>]
        #Option     "CrtcNumber"                # <i>
        #Option     "FPScale"                   # [<bool>]
        #Option     "FPTweak"                   # <i>
        Option "NvAGP" "1"
        Identifier  "Card0"
        Driver      "nvidia"
        VendorName  "nVidia Corporation"
        BoardName   "Unknown Board"
        BusID       "AGP:01:00:0"

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        DefaultDepth 24
        SubSection "Display"
                Viewport   0 0
                Depth     1
        SubSection "Display"
                Viewport   0 0
                Depth     4
        SubSection "Display"
                Viewport   0 0
                Depth     8
        SubSection "Display"
                Viewport   0 0
                Depth     15
        SubSection "Display"
                Viewport   0 0
                Depth     16
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes   "1280x1024"

More information about the freebsd-questions mailing list