apache problem

Vizion vizion at vizion.occoxmail.com
Tue Mar 6 16:25:12 UTC 2007

> -----Original Message-----
> From: owner-freebsd-questions at freebsd.org 
> [mailto:owner-freebsd-questions at freebsd.org] On Behalf Of eoghan
> Sent: Tuesday, March 06, 2007 5:50 AM
> To: freebsd
> Subject: apache problem
> Hi
> I am running apache 2.2.4 on FreeBSD 6.1. This is a recent 
> upgrade from ports (in the past few days or so). Since then I 
> cant browse to localhost. Just get an unable to connect 
> message. The server seems to start with:
> $sudo apachectl start
> If I try it again I see its already running.
> My error log shows:
> [Mon Mar 05 11:20:00 2007] [notice] Apache/2.2.4 (FreeBSD)
> mod_ssl/2.2.4 OpenSSL/0.9.7e-p1 DAV/2 PHP/5.2.1 with Suhosin-Patch
> configured -- resuming normal operations
> [Mon Mar 05 11:20:22 2007] [notice] caught SIGTERM, shutting down
> I have tried the apache list but no real answers, and apache 
> was working fine for me before I upgraded. Has anyone else 
> noticed this since an upgrade to the 2.2.4 version from ports?
> Thanks
> Eoghan

I had the same problem. Here is how I fixed it:
#apachectl stop
# cd /usr/ports/www/apache22
#make clean
# make deinstall
# rm ./*
Then do a cvsup ports all
now once more
#cd /usr/ports/www/apache22
# make (it will use your stored config)
#make install
#make clean
#apachectl start

More information about the freebsd-questions mailing list