Users unable to write to mounted FAT32 partition

Michael G. mikegoe at
Sat Mar 3 02:07:36 UTC 2007

     A mod of your suggestion did the trick.  I was unable to finally 
"chown Michael /mydos" and then change permissions using chmod.  Seems 
pretty simple but kinda strange that as root I could not change the 

Thanks to you and Jerry for all the help!

Michael G.

Chris Hill wrote:
> On Fri, 2 Mar 2007, Michael G. wrote:
>> Owner of /mydos is root and Group is wheel.  User has rwx while Group 
>> and Other only have r-x
> Well, there it is. I think users who want to write to this filesystem 
> need to have write permission on the mountpoint. How about creating a 
> group, perhaps "users", of which all users are members, then chown 
> root:users /mydos, then chmod 775 /mydos
>> Jerry McAllister wrote:
>>> On Fri, Mar 02, 2007 at 05:14:14PM -0600, Michael G. wrote:
>>>> OK, I've scoured the archives for an answer with no results.  I'm 
>>>> sharing a FAT32 partition between XP and 6.2 Release.  The problem 
>>>> is I can mount the drive but only root can write to it (users can 
>>>> just read).  I have the following in fstab:
>>>> /dev/asd42        /mydos        msdosfs     rw  0 0
>>>> I've tried adding the -u or -g option with no luck.  I understand 
>>>> that since FAT has no inherent permissions chmod has no effect 
>>>> either (tried it just to be sure) so it must be set from fstab. Any 
>>>> help?
>>> What are the owner and permissions on the mount point  (/mydos)?

More information about the freebsd-questions mailing list