transcode compilation error

beni beni at
Tue Jul 31 17:22:00 UTC 2007

On Tuesday 31 July 2007 06:54:34 illoai at wrote:
> On 30/07/07, Tsu-Fan Cheng <tfcheng at> wrote:
> > hi,
> >   just updated the ports and found out about the thing about automake.
> > So, do as told, and transcode is having problems:
> >
> > aud_aux.c: In function `audio_init_ffmpeg':
> > aud_aux.c:364: error: `ac3_encoder' undeclared (first use in this
> > function) aud_aux.c:364: error: (Each undeclared identifier is reported
> > only once aud_aux.c:364: error: for each function it appears in.)
> > aud_aux.c:365: error: `mp2_encoder' undeclared (first use in this
> > function) gmake[2]: *** [aud_aux.lo] Error 1
> >
> > I do have liba52 installed, any idea??
> multimedia/ffmpeg was recently updated, and portupgrade
> is not always great about ordering dependencies well: per-
> haps upgrade ffmpeg and then transcode?
> NB: I do not have transcode installed and honestly don't
> know what good it would do.
> PS:  If that didn't work, I would try:
> # portupgrade -rRf transcode
> and if that didn't work I would throw something and work with
> # portupgrade -Rrf
> somewhere else in transcode's depandency tree and hope
> that it got sucked in correctly (it usually does).

Not a solution but the same problem here... :-( 
I've tried to portupgrade -rRf and even a "make deinstall" with a "make 
reinstall" but still no good.
Even deinstalled ffmpeg but still nothing : transcode pulls ffmpeg back in, 
installs it fine but crashes during the make.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: This is a digitally signed message part.
Url :

More information about the freebsd-questions mailing list