unable to "SITE CHMOD" via ftp (all users)

Dinesh Pandian dineshpandian at gmail.com
Sun Jul 29 15:59:06 UTC 2007

Sorry guys. It was as simple as chowning the files properly.
Not sure how I overlooked that! Extremely sorry for the trouble.
Solved the problem.

Have a great day, guys.


On 7/29/07, Dinesh Pandian <dineshpandian at gmail.com> wrote:
> Good day to all.
> I use proftpd 1.3.1rc3 from the ports and I'm unable to chmod
> any files in the home directory when logged in as any user.
> The following is my proftpd.conf file, though I believe
> it's the proftpd's fault. Same error is found in pure-ftpd,
> even when chmod is allowed in both ftpd's conf files.
> <Limit SITE_CHMOD>
> AllowAll
> </Limit>
> <Global>
> AllowForeignAddress on
> AllowRetrieveRestart on
> AllowStoreRestart on
> IdentLookups off
> DefaultRoot ~
> </Global>
> I believe it's some permission problems with
> the users in freebsd itself and has nothing to do
> with the ftp server programs. The following is output
> from uname -a:
> FreeBSD solara.com.my 6.2-RELEASE-p5 FreeBSD 6.2-RELEASE-p5 #3: Tue Jul 24
> 16:20:42 MYT 2007
> root at solara.com.my:/usr/obj/usr/src/sys/SOLARA  i386
> I've been trying to find a solution for quite some time,
> and write to this group as a last resort. Please help.
> TIA.
> --
> Regards,
> Dinesh Pandian,

Dinesh Pandian,
SOLARA Networks.

More information about the freebsd-questions mailing list