Upgraded Samba and Can't Connect with Win XP -- SOLVED!!!

Drew Tomlinson drew at mykitchentable.net
Sun Jul 29 14:52:58 UTC 2007

On 7/29/2007 4:46 AM Rakhesh Sasidharan said the following:
> On Sun, July 29, 2007 01:51, Drew Tomlinson wrote:
>> I upgraded samba to 3.0.25a from 3.0.24.  Now I can't connect with
>> Windows XP clients however smbclient both locally and remotely works
>> just fine.  Basically when connecting from Windows XP, I see the
>> connection in log.smbd and then it's immediately closed.  See this snip:
>> [2007/07/28 14:36:25, 1] smbd/service.c:make_connection_snum(1033)
>>   bigdaddy ( connect to service Archive initially as user
>> <user name> (uid=0, gid=1001) (pid 82696)
>> [2007/07/28 14:36:25, 1] smbd/service.c:close_cnum(1230)
>>   bigdaddy ( closed connection to service Archive
>> The Windows machine was working fine with Samba before the upgrade.  Any
>> ideas what changed?  I've read UPDATING and the samba docs but see
>> nothing that addresses my symptoms.  Google hasn't helped either.
> I recollect having some problems while upgrading from Samba 3.0.24 to
> 3.0.25. In my case, however, Samba kept crashing and complained about some
> corrupt .tdb files. Finally I deleted all the files in /var/db/samba and
> that fixed it for good.
> One thing that caught my attention in your snippet is the "uid=0" part. Is
> your Windows user you are trying to connect as mapping to the Samba
> machine's root user? The first time I installed Samba I had made some
> mistakes in the config file and so my Windows user was getting mapped to
> uid 0 thus getting denied by Samba (coz I had defined root as an invalid
> user for security reasons). Maybe something like that is your problem?
> Regards,
> Rakhesh

Thanks for your reply.  Oddly enough, rebooting the Windows clients has 
solved the problem.  Windows must have been caching something that 
prevented it from staying connected to the new version.

I hadn't noticed uid=0.  Thanks for pointing that out as I'm sure it's a 
potential security issue.  I was attempting to log on as myself which 
should have a uid=1000.



Be a Great Magician!
Visit The Alchemist's Warehouse


More information about the freebsd-questions mailing list