Nothing happens with Qemu

Rakhesh Sasidharan rakhesh at
Sun Jul 29 13:53:18 UTC 2007


I'm trying to get Qemu working on my FreeBSD 6.2 PC. But nothing seems to
be happening. I posted my problem at the Qemu forums but haven't got any
replies there (I wonder if any one even uses those forums coz mine is like
the last post there!) Just trying my luck here too in case I get some
tips/ ideas.

Installed Qemu from the ports. Without SDL (coz I don't have X etc
installed and I just SSH into this box). With KQEMU module. After that I
ran "/usr/local/etc/rc.d/kqemu" for loading the modules "aio" and "kqemu".
All went fine.

Next I created a 2G image. "qemu-img create /tmp/something.img 2G". That
too went fine.

Then I tried to install some OS into this image. Put the CD in the drive,
and tried "qemu -boot d -cdrom /dev/acd0 -hda /tmp/something.img". But
nothing happens! The CD starts spinning in the drive but nothing happens
after that. I ran "top" and I can see the qemu process is active and
taking some 128MB memory, but there's no other signs of life.

I tried the above with two OSes. I tried with an Ubuntu server and also an
OpenBSD 4.1. Tried both to make sure its not a OS specific problem. I even
ripped the CDs to ISO files and tried running from that (coz I read
someplace that FreeBSD Qemu has problems reading from CDs). But no luck
... whatever I do, nothing happens.

I also tried with the "-full-screen" option. But no go.

Finally, I tried running with the -nographic option. I remm reading
somewhere that that usually helps. That time I get a "(qemu)" prompt and
that's it -- nothing happens. Tried stuff like Ctrl+Alt+1,2,F, etc but
nothing happens. Can't even Ctrl-C out. Finally had to kill the process
from another terminal.

I also tried with the option -monitor stdio. That gives me a (qemu) prompt
in which I can type commands. But I couldn't figure a way to proceed
further after that.

I tried all these steps through SSH as well as on the console (including
uncommenting the console entry in /etc/tty and trying). No luck.

Any ideas what could be going wrong? I figure it must be something to do
with me not having X and not compiling Qemu with SDL/ X support ... is
that the case?


More information about the freebsd-questions mailing list