ssh X11 forwarding not working on FreeBSD 6.2

Josh Paetzel josh at
Tue Jul 24 21:41:37 UTC 2007

On Tuesday 24 July 2007, Pollywog wrote:
> On Tuesday 24 July 2007 15:59:22 Terry Todd wrote:
> > I have installed Xming successfully on a Windows XP system.
> > It works OK to a FC6 system and an older UNIXware system.
> >
> > However when trying to connect to a FreeBSD 6.2 system with PuTTY
> > ssh it doesn't work.  PuTTY has Enable X11 forwarding checked.
> When I saw this post, I thought it was mine, because I am having
> the same problem, but only in FreeBSD and not Linux and my
> configurations on both are very much the same (for sshd).
> I am also unable to use port forwarding in vnc (fbsd 6.2) but I am
> not certain whether this is related to the X11 Forwarding issue or
> if it is something unrelated.  SSH complains that it cannot use the
> designated port (I have tried different ports.
> BTW I can do SSH port forwarding from my fbsd computer (client) to
> Linux (server) but cannot do this from Linux to fbsd.
> I changed
> X11DisplayOffset 10
> to
> X11DisplayOffset 1
> as mentioned in another post in this thread but that did not help.

Is tcp listening still off by default on FreeBSD?  Last time I tried 
to do anything with remote X (which was ages ago) I had to find the 
goo that was disabling it, I think it was tcp nolisten or something 
in the startx script.

Mind you we are talking FBSD 4.x here, but the errors seem very 


Josh Paetzel
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list