Garrett Cooper youshi10 at
Sun Jul 15 22:44:31 UTC 2007

Roland Smith wrote:
> On Sun, Jul 15, 2007 at 05:25:46PM -0400, Michael B Allen wrote:
>> Hello,
>> I'm a C developer. I normally use Linux but I'm trying FreeBSD with
>> limited success.
>> First thing I need to do mount an NFS volume. I was able to mount it
>> manually. Fine. Then I added an entry to, did 'amd /mnt
>> /etc/' and tried to access the directory in /mnt and it worked.
>> Fine. Then I killed amd, tried and failed to figure out how to get amd
>> to start automatically on boot. Then I tried to start amd again as
>> before and now it doesn't work:
> Daemons are enabled in /etc/rc.conf. You can see the defaults in
> /etc/defaults/rc.conf. 
> For amd and nfs you should have the following in /etc/rc.conf:
> rpcbind_enable="YES"
> amd_enable="YES"
> nfs_client_enable="YES"
> Section §24.3 of the FreeBSD handbook can enlighten you further. You can
> find an english HTML version in 
> file:///usr/share/doc/en_US.ISO8859-1/books/handbook/network-nfs.html
> Reading the relevant sections of the Handbook if a good way to become
> acquainted with FreeBSD.
> Roland
    The online equivalent of the handbook chapter is: 
with the section in amd here: 
    If you follow the directions and still have issues, please include 
relevant snippets from rc.conf, your amd maps, and /etc/exports.
    Don't forget to run showexport -e {hostname|IP} on the remote 
server. It can help you determine if the problem is present on the 
server or the client.
    Best of luck and hope you do well getting used to FreeBSD.

More information about the freebsd-questions mailing list