without SSL

pj af.gourmet at videotron.ca
Thu Jul 12 14:17:39 UTC 2007

I must apologise for my screw-up.
Apache is working fine.
The problem was that when I sought to access Webmin i got the message : 
This server is running in ssl mode. I assumed it was apache, not 
realizing that port 10000 took me to the Webmin server.
To clear things up, apache2.2.4 apparently automatically compiles with 
SSL, but SSL is only active if it is configured with certificates etc. 
and probably needs an installation of OpenSSL.

Thanks much for your help; you steered me in the right direction.

Daniel Marsh wrote:
> On 7/12/07, *pj* <af.gourmet at videotron.ca 
> <mailto:af.gourmet at videotron.ca>> wrote:
>     Chuck Swiger wrote:
>      > On Jul 11, 2007, at 10:22 AM, pj wrote:
>      >> I can access apache from my windows machine: "It works"
>      >> But I cannot access http://biggie:10000 <http://biggie:10000> -
>     message says: try https://...
>      >> that does bring up the Webmin page. I know apache listens on
>     port 80,
>      >> but why https to get the Webmin page?
>      >
>      > Umm, so you don't send your Webmin password through the Internet in
>      > plain text, rather than via SSL encryption.
>     I only use the server locally on my local network so I don't need
>     the SSL.
>      >
>      > Webmin uses it's own internal webserver, which is unrelated to
>     Apache.
>     OK, thanks for that, I didn't know.
>      >
>      >> I cannot access http or https://biggie:931 (Swat) "Unable to
>     connect"
>      >
>      > There's no real need to use swat when you've got the ability to
>     edit the
>      > samba config directly or via Webmin, but if you really wanted to, you
>      > could presumably set it up to run in inetd.conf.  See "man swat".
>     Agreed. I don't like to use Webmin except to see if I may have missed
>     something. It does not have the correct settings on startup.
>      >
>      >> Is my configuration wrong for samba? What's with the ssl?
>      >
>      > You haven't provided any specific information about your Samba
>     config,
>      > and most people aren't good at reading minds, so you'll need to
>     either
>      > do something like run Samba's "testparms" and/or look over the Samba
>      > logfiles....
>     I finally found that Samba was looking for a guest account - I had not
>     set it up. Now it's working ok.
>      >
>      >> I tried to reinstall (unsuccessfully -D NOSSL) apache22 without SSL.
>      >> How can I disable the SSL I don't need SSL as I am using FBSD6.2
>     only
>      >> on my local network.
>      >
>      > Unless you've configured an SSL cert, the default ought to be to run
>      > Apache without SSL...?
>     I have not configured the SSL cert but no matter what I do, apache still
>     runs with SSL. According to the manuals, apache is compiled with SSL by
>     default for version 2.2.4. I have tried to # the ssl_module in
>     httpd.conf with no results at all. That was the first thing I actually
>     tried when I saw it was running SSL.
>      >
>      > ---Chuck
> Show us your httpd.conf?

> It's probably something as simple as uncommenting everything to do with 
> SSL in httpd.conf, if compiled with SSL, Apache likes to automagically 
> setup a virtual host using SSL.
> There should also be a command line argument to apachectl or httpd that 
> can be set with apache_flags="--disable-ssl" (or something similar) so 
> the RC scripts know how to load Apache. Read through 
> /usr/local/etc/rc.d/apache-script, you'll get some information through 
> that.

More information about the freebsd-questions mailing list