without SSL

pj af.gourmet at videotron.ca
Thu Jul 12 02:33:59 UTC 2007

Chuck Swiger wrote:
> On Jul 11, 2007, at 10:22 AM, pj wrote:
>> I can access apache from my windows machine: "It works"
>> But I cannot access http://biggie:10000 - message says: try https://...
>> that does bring up the Webmin page. I know apache listens on port 80, 
>> but why https to get the Webmin page?
> Umm, so you don't send your Webmin password through the Internet in 
> plain text, rather than via SSL encryption.
I only use the server locally on my local network so I don't need the SSL.
> Webmin uses it's own internal webserver, which is unrelated to Apache.
OK, thanks for that, I didn't know.
>> I cannot access http or https://biggie:931 (Swat) "Unable to connect"
> There's no real need to use swat when you've got the ability to edit the 
> samba config directly or via Webmin, but if you really wanted to, you 
> could presumably set it up to run in inetd.conf.  See "man swat".
Agreed. I don't like to use Webmin except to see if I may have missed 
something. It does not have the correct settings on startup.
>> Is my configuration wrong for samba? What's with the ssl?
> You haven't provided any specific information about your Samba config, 
> and most people aren't good at reading minds, so you'll need to either 
> do something like run Samba's "testparms" and/or look over the Samba 
> logfiles....
I finally found that Samba was looking for a guest account - I had not 
set it up. Now it's working ok.
>> I tried to reinstall (unsuccessfully -D NOSSL) apache22 without SSL. 
>> How can I disable the SSL I don't need SSL as I am using FBSD6.2 only 
>> on my local network.
> Unless you've configured an SSL cert, the default ought to be to run 
> Apache without SSL...?
I have not configured the SSL cert but no matter what I do, apache still 
runs with SSL. According to the manuals, apache is compiled with SSL by 
default for version 2.2.4. I have tried to # the ssl_module in 
httpd.conf with no results at all. That was the first thing I actually 
tried when I saw it was running SSL.
> ---Chuck

More information about the freebsd-questions mailing list