The worst error message in history belongs to... BIND9!

Ted Mittelstaedt tedm at
Thu Jul 5 08:26:51 UTC 2007

> -----Original Message-----
> From: owner-freebsd-questions at
> [mailto:owner-freebsd-questions at]On Behalf Of Gerard
> Sent: Wednesday, July 04, 2007 9:30 AM
> To: User Questions
> Subject: Re[2]: The worst error message in history belongs to... BIND9!
> On July 04, 2007 at 09:53AM Ted Mittelstaedt wrote:
> [snip]
> > Actually perl has a lot of problems too.  One of the biggest is that
> > perl script writers always seem to think like you, in that perl is
> > consistent across all platforms.
> > 
> > The biggest problems I've seen with perl scripts are when people use
> > perl extensions that are not on the system.  You then have to go find
> > the extension they use and very few of the perl script writers seem
> > to be smart enough to put a section at the beginning of their scripts
> > that define the CPAN location of the particular extensions they are
> > using.  The second biggest problem is perl script writers using
> > constructs that are valid in Perl 5.6 and later but not valid in
> > Perl 5.0   I don't know how many times I've wanted to strangle
> > someone when trying to run a perl script under Perl 5.0 that had
> > ONE single friggin statement in the entire thousand line script that
> > isn't valid under 5.0 but is under 5.6  And I've also run across
> > a number of Perl extensions that won't run under 5.0 as well, even
> > though the authors are supposed to regression test under 5.0
> I was under the impression that Perl 5.6.0 was released on 2000-Mar-22,
> while Perl 5.000 was issued on or about 1994-Oct-17. For the life of
> me, I cannot comprehend why anyone would be using such an antiquated
> version.

I should have said the perl 5.0 family.  Including 5.004 which is still
being maintained by the Perl maintainers.  Perl 5.005-04 just came out
in 2004 by the way.  perl 5.6.2 came out in Nov 2003.

> I have a rather limited knowledge of Perl;

That's apparent.

> however, I am not
> going to be bothered regression testing it under a seven year old
> obsoleted version. 

There were major structural changes in perl 5.0 and 5.6  The changes
going from 5.6 to 5.8 and 5.9 are much less.

You can take it as a given that anything that runs on perl 5.005-04 
will run on all perl 5.0 versions, anything that runs on perl 5.6.2
will run on all 5.6 versions, etc.

The whole reason that the perl project maintains 5.0, 5.6, 5.8 and
so on is that they know that there's systems that have lots of tested
programs that have been tested under 5.0 and the system maintainers
have not yet gone through the process of testing all that software
on newer perl versions.  Despite what you probably believe, when
an organization has a server that is running fine, they are not
frothing at the mouth to upgrade it to the latest version.

This is why IMHO that perl is not a good choice to use for building
large systems, not because the perl maintainers don't understand
the importance of backwards compatability, but because too many 
programmers like yourself simply don't.

If I was building a system that was ONLY going to use perl and
the modules supplied with it, and NOT use any other 3rd party
modules, then I would consider using perl, there wouldn't be
anything wrong with it.

But most of the perl scripts out there use many 3rd party modules
(and I understand why, it saves them time) and that is where you have
the problem, is with those.

> I believe that FreeBSD-3.4 was released around
> 12/21/1999 or there about. Should we also be testing against that
> version also?

I wasn't talking about 1999 software I was talking about 2004


More information about the freebsd-questions mailing list