python upgrade issue

Zbigniew Szalbot zbyszek at
Mon Jan 29 17:06:51 UTC 2007


I am running FreeBSD 6.2-RELEASE. Today I tried upgrading python to its
most recent version. I made sure version 2.5 is mentioned in distinfo file
and then issued portupgrade. I was not really convinced from the initial
screen that my box was going to get the latest release but anyway the
upgrade process stopped in the middle (most likely because I was remotely
connected and my wLAN connection suddenly died for a second). So I tried
again but got "** No such installed package: lang/python" response. When I
do python -V, I get Python 2.4.3. And luckilly python is still there as my
mailman needs it.

I used cvusp to refresh ports collection and tried portupgrade again but
with the same error message. For one, I am not worried since current
python clearly works but could you please suggest if/how I should made the
system available for a python upgrade?

Thank you very much in advance!

Warm regards,

Zbigniew Szalbot

More information about the freebsd-questions mailing list