FreeBSD 6.1 & 6.2 hanging and/or spontaneous rebooting

Joe Vender jvender at
Sat Jan 27 14:09:01 UTC 2007

On Saturday 27 January 2007 00:41, Ian Smith wrote:
> In freebsd-questions Digest, Vol 162, Issue 17
> As Message: 14
> On Fri, 26 Jan 2007 14:15:10 -0600 Joe Vender <jvender at>
> wrote:
> Joe, I'm going to hack your message pretty mercilessly ..
>  > I need Help with a FBSD spontaneous rebooting and freezing issue.
>  >
>  > Here's a quick description of my computer system:
>  >
>  > I have a Compaq Presario 5184 desktop about 7 or 8 years old
>  > AMD K6-2 processor @ 380MHz
>  > 320Mb RAM, 8Mb dedicated to video via BIOS
>  > Quantum Bigfoot TS-6.4A Hard Drive (~6Gb capacity)
>  > SiS 530 integrated graphics
>  > Zoom 56k DUALMODE external modem connected to the serial port
>  > CTX VL700 monitor (30-70/50-120 refresh rates)
> [..]
>  > worked fine under FBSD until I dial up the internet and start browsing,
>  > emailing or whatever. Then, when the computer is busy transferring
>  > packets, it suddenly reboots without warning. Sometimes, Konqueror will
>  > freeze, the mouse pointer will freeze for a few seconds before the
>  > reboot. It doesn't take very long on the internet before the
>  > lockup/reboot happens, only minutes. It happens over and over and over.
>  > I can't stay on the internet long enough to even use it.
> Nothing at all reported in /var/log/messages?
Not that I can recall. As I stated earlier, I had to remove FBSD and install 
Linux to be able to use this mailing list, but I did look through the logs 
after the spontaneous reboots and found nothing that indicated what was 

>  > Remember, the spontaneous reboots and hangs only happen when I dial up
>  > the internet and start browsing or sending email or such, basically
>  > start sending/receiving packets. It doesn't happen when no packets are
>  > moving over the modem, only when its busy. It isn't the modem failing
>  > either, obviously, since the modem works flawlessly under Linux and
>  > windows.
> Ok.  You mean it sometimes 'hangs' and sometimes just reboots?

When I was using FBSD 6.1, it was always a spontaneous reboot, but the system 
would usually freeze for a couple of seconds before the reboot occurred. I 
found a notice in the errata on the FBSD website that sounded like it 
addressed what could be causing this problem: "", and I 
applied the patch to 6.1 and rebuilt the kernel. I thought that this had 
fixed the problem because I didn't get a spontaneous reboot after being on 
the net for a short time. But, I was wrong because It did spontaneous reboot, 
just not immediately after starting to use the net. So, that's when I moved 
on to FBSD 6.2. After setting it up to dial up using KPPP, I was on the net 
for maybe a half hour when it suddenly froze up. The computer was locked up. 
I had to hard reboot using the power button. After that, I put linux back on 
the system to seek help, since I didn't know what the problem was and I 
coundn't use FBSD to seek help.

>  > One more thing that may or may not be important. I remember seeing a
>  > message at boot up about "IRQ 3 not in the list of probed ports" or
>  > something to that effect. But, KPPP recognized my external modem without
>  > a problem. Its on /dev/ttyS0 in KPPP. My computer came with an internal
>  > "winmodem" piece of @#!$, but I removed that when I plugged in the Zoom
>  > external. The internal modem is no longer present. The external is
>  > plugged in to the serial port. Could this be an IRQ conflict or
>  > something like that? I'm assuming that the message was about the absent
>  > internal modem. "Interrupts" in KInfoCenter reports that "serial" is
>  > using interrupt 4. Please help. I don't mind going through the reinstall
>  > if I can get FreeBSD working.
> Ah, so you're using KPPP rather than FreeBSD's user PPP?  Have you tried
> using 'regular' user PPP? 

No. I'm new to FreeBSD, and KPPP was quicker and easier for me to get up and 
going, plus I like to have the icon docked into the system tray when I'm 

> I don't know anything about KPPP, but would 
> expect with KDE's linux leanings that it would be using pppd instead.
> Where and how have you configured ppp?
I configured KPPP with the info needed to dial up.

> In ancient PC tradition, IRQ 4 is used for the first serial port, IRQ 3
> for the second.  Eg from /var/run/dmesg.boot here (also an older box):
>  sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
>  sio0: type 16550A
> I have sio1 disabled in /boot/loader.conf, just to quell such messages,
> but it seems yours is using the correct IRQ (4) for your ext. modem.

My computer originally came with an internal modem which was on COM1 under 
windows. COM2 would have been the serial nipple on the back of the computer. 
I removed the internal modem, and when I attached the external modem, I 
assume the serial controller on the motherboard reassigned the external 
nipple to COM1 and disabled COM2. The internal slot is empty, which I guess 
is why FBSD throws the error message about it being disabled.

>  > One last question. How do I get FBSD to completely power off my computer
>  > when I shut down, both from KDE and from console? When I shutdown, it
>  > just gets to the "system halted, press any key to reboot" prompt and
>  > doesn't completely power off. In slackware, all I have to do is
>  > uncomment the "modprobe apm" line in rc.modules.
> Well that begs more questions.  Are you using APM? or ACPI?  What exact
> command are you using to shutdown?  What does running just 'apm' say?

Well, using windows it was called advanced power management. Using linux, I 
load the apm module via "modprobe apm". I think that my computer is too old 
to be able to use ACPI. I think that came out a couple of years after my 
computer was manufactured. I think I need the APM module, not the ACPI. I 
haven't recompiled the FBSD kernel with APM enabled and ACPI disabled, but I 
can. I remember reading somewhere, manual?, that they must not both be 
enabled at the same time, but to use only one and disable the other.

>  > Sorry for such a long email, but I wanted to be as thourough as possible
>  > with the little I have to go on.
> Posting latest /var/run/dmesg.boot would tell us more about what FreeBSD
> thinks it's detecting, and I suspect that setting up user PPP by the
> handbook would determine whether this is a FreeBSD or KPPP problem.

OK. I will reinstall FBSD 6.2 and try to get the logs to you today if I have 
time. If not today, then in a day or two for sure.

Thanks to all for the help and suggestions! I know I can get FBSD working on 
this computer. Its a honey of an OS. I love how easy it is to encrypt the 
swap partition, and the new kernel mode auditing features are a sweet 
addition to a great system. FBSD had a bright future. I can't find anything 
that I don't like, except that I can't use it (on the internet)...YET! ;)

> Cheers, Ian

More information about the freebsd-questions mailing list