FreeBSD 6.1 & 6.2 hanging and/or spontaneous rebooting

Derek Ragona derek at
Fri Jan 26 21:05:28 UTC 2007

Sounds like an IRQ conflict as your serial port is not on IRQ 3.  I would 
look into the BIOS settings, and set the port explicitly for IRQ 3, and not 
automatic if this is possible.


At 02:15 PM 1/26/2007, Joe Vender wrote:
>I need Help with a FBSD spontaneous rebooting and freezing issue.
>Here's a quick description of my computer system:
>I have a Compaq Presario 5184 desktop about 7 or 8 years old
>AMD K6-2 processor @ 380MHz
>320Mb RAM, 8Mb dedicated to video via BIOS
>Quantum Bigfoot TS-6.4A Hard Drive (~6Gb capacity)
>SiS 530 integrated graphics
>Zoom 56k DUALMODE external modem connected to the serial port
>CTX VL700 monitor (30-70/50-120 refresh rates)
>I'm new to FreeBSD, but I've some experience with Linux, so FreeBSD isn't
>totally unfamiliar to me.
>I zero-filled my HDD on which I'd been running Slackware 11.0 without issue
>and started from scratch with a clean install of FreeBSD 6.1-release. FreeBSD
>6.1 was then the only OS on the system, no multi-boot environment. Everything
>worked fine under FBSD until I dial up the internet and start browsing,
>emailing or whatever. Then, when the computer is busy transferring packets,
>it suddenly reboots without warning. Sometimes, Konqueror will freeze, the
>mouse pointer will freeze for a few seconds before the reboot. It doesn't
>take very long on the internet before the lockup/reboot happens, only
>minutes. It happens over and over and over. I can't stay on the internet long
>enough to even use it.
>Now, I've been using Slackware Linux without issue for a long time, same with
>Ubuntu & Kubuntu & Windows prior to that. This isn't a hardware failure,
>because it doesn't occur with these other OSs at all. Linux was what I was
>using before I wiped the drive and installed FreeBSD. I've tested the RAM and
>HDD and they are OK. I repeat, there are no problems like this with the other
>OS's, only when FreeBSD is put on the system. I've only tried FBSD
>6.1-release & FBSD 6.2-release, nothing prior to that.
>Since I wasn't even able to use the internet because of the freeze/reboot, I
>reinstalled Slackware and, as always, it is running without a hitch. But, I
>want to use FreeBSD, so I got a copy of FreeBSD 6.2 CDs, thinking maybe it
>was a fixed in the new release. FreeBSD 6.2 gives me the same behavior. After
>a few minutes of browsing, the system just froze up and required a hard
>I REALLY like FreeBSD, the features and ease of use. If I could get it 
>on this computer as smoothly as Slackware does, I'd use it exclusively. This
>is the only computer I have, so in order to even send this message, I had to
>put Slackware back on the computer. That's what I'm using now.
>If anyone can help me figure out what the problem is here, I'd really
>appreciate it.
>Remember, the spontaneous reboots and hangs only happen when I dial up the
>internet and start browsing or sending email or such, basically start
>sending/receiving packets. It doesn't happen when no packets are moving over
>the modem, only when its busy. It isn't the modem failing either, obviously,
>since the modem works flawlessly under Linux and windows.
>Keep in mind that this is my only computer. I will have to wipe the HDD and
>reinstall FBSD in order to try any suggestions, so please give as much info
>as possible, since when I'm back to FBSD, I may not be able to get back on
>the net for further communication if I can't fix the problem first. At least,
>not until I go through the process of reinstalling Slackware.
>I'm hoping that someone has run into this problem before and knows a way to
>fix it.
>One more thing that may or may not be important. I remember seeing a message
>at boot up about "IRQ 3 not in the list of probed ports" or something to that
>effect. But, KPPP recognized my external modem without a problem. Its
>on /dev/ttyS0 in KPPP. My computer came with an internal "winmodem" piece of
>@#!$, but I removed that when I plugged in the Zoom external. The internal
>modem is no longer present. The external is plugged in to the serial port.
>Could this be an IRQ conflict or something like that? I'm assuming that the
>message was about the absent internal modem. "Interrupts" in KInfoCenter
>reports that "serial" is using interrupt 4. Please help. I don't mind going
>through the reinstall if I can get FreeBSD working.
>One last question. How do I get FBSD to completely power off my computer when
>I shut down, both from KDE and from console? When I shutdown, it just gets to
>the "system halted, press any key to reboot" prompt and doesn't completely
>power off. In slackware, all I have to do is uncomment the "modprobe apm"
>line in rc.modules.
>Sorry for such a long email, but I wanted to be as thourough as possible with
>the little I have to go on.
>freebsd-questions at mailing list
>To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"
>This message has been scanned for viruses and
>dangerous content by MailScanner, and is
>believed to be clean.
>MailScanner thanks transtec Computers for their support.

This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.
MailScanner thanks transtec Computers for their support.

More information about the freebsd-questions mailing list