ping: sendto: Can't assign requested address

Questions questions at
Thu Jan 18 17:08:35 UTC 2007


Let me preface this mail by saying:  I'm an idiot.

Now that we've gotten that out of the way, you don't have to say it!

I have a piece of networking equipment that does not have a "factory
defaults" button on it.   it has to be RMA'd and returned to the
manufacturer if you can't remember login credentials (forgot
username,pass/IP, etc)

I was assigning the unit an IP address of 172.20.1.x but I typod it.   
127.20.1.x and as you can guess,  I can't connect to the unit from any
other device now.   127.x is loopback.

I have tried assigning a 127.20.1.x address to an ethernet interface in a
FreeBSD box,  and removinging the on localhost.   I've also
gone into the routing table,  and removed all traces of routes for 127.x 
and finally,  *tried* creating a route for 127.20.1.x to go out the
ethernet interface (link #2)

The problem with everything above is:  no matter what ip/subnet
combination I use, I get a message (when adding the route) that the
network is unreachable.   Then,  when I try to ping the device from the
fbsd box,  I get "ping: sendto: Can't assign requested address"

My question is:  Is it possible in any way, to change the 127 routing to
pass out my ethernet card long enough to re-ip this device?  I haven't yet
come up with a decent solution.

Thanks for any thoughts,


More information about the freebsd-questions mailing list