Can't make raid array bootable

odilist at odilist at
Mon Feb 26 04:14:29 UTC 2007


I've tried transferring my system (6.0) to an Nvidia hardware raid array
of two SATA drives on an Asus A8N-E motherboard, following the
instructions in the FAQ. I can't seem to use fdisk to make the array
bootable, or to rewrite the master boot record. It claims to write the
information to disk and then, when I check again, nothing has stuck. I
have tried fdisk -B -b ar0, boot0cfg -s 1 ar0, boot0cfg -B ar0, and
probably many other things in the course of the day, but so far I am
rewarded only with:

Invalid partition
Invalid partition
No boot/loader

Boot defaults to an ad(0,a) which doesn't exist.

Further, diskeditor has just started showing two partitions, one which is
the primary of the raid and the other being the array itself. As the raid
section of the handbook says "the disk(s) will look like a single drive to
FreeBSD," this concerns me.

Would anyone have any ideas?


More information about the freebsd-questions mailing list