ssh to VMS - terminal problems

Anton Shterenlikht mexas at
Tue Feb 20 16:10:35 UTC 2007


I connect to a VMS box from my FreeBSD laptop via ssh.
When I run a full screen text editor (EDIT) my terminal screen behaves
unpredictably: cursor jumps from place to place, keystrokes produce
characters in unpredictable places, screen menu flows with the text
rather than stay at the bottom. Hovewer, if I scroll the offending
bit up of down from the screen and back into the screen I can see
my changes. I assume the problem lies in some terminal incompartibility.

My box is
% uname -a
6.2-PRERELEASE FreeBSD #0: Wed Nov 22 09:36:22 GMT 2006
 root@:/usr/obj/usr/src/sys/SC  i386

I had exactly the same problem with 6.1.

I use sc driver. In a desperate attempt to resolve the problem I tried
pcvt driver, but that seems to be faulty and no longer supported, freezes
screen and the keyboard. However, I'm not sure if the actual driver
 has anything to do with my problem.

At the moment I use
% echo $TERM

but I tried several other terminals I found in /etc/termcap, including
various VT terminals. This is when I tried to use pcvt instead of sc,
because I thought that maybe a VT term requires pcvt driver. Does it
make any sense?

On the other hand I tried to change terminal settings on the VMS box,
which are many. At present these look as follows:

 $ show terminal/full
Terminal: _FTA20:     Device_Type: VT100         Owner: MEXAS

   Input:    9600     LFfill:  0      Width:  80      Parity: None
   Output:   9600     CRfill:  0      Page:   24

Terminal Characteristics:
   Interactive        Echo               Type_ahead         No Escape
   Hostsync           TTsync             Lowercase          Tab
   Wrap               Scope              No Remote          No Eightbit
   Broadcast          No Readsync        No Form            Fulldup
   No Modem           No Local_echo      No Autobaud        No Hangup
   No Brdcstmbx       No DMA             No Altypeahd       Set_speed
   No Commsync        Line Editing       Overstrike editing No Fallback
   No Dialup          Secure server      No Disconnect      No Pasthru
   No Syspassword     No SIXEL Graphics  No Soft Characters No Printer Port
   Numeric Keypad     ANSI_CRT           No Regis           No Block_mode
   Advanced_video     No Edit_mode       DEC_CRT            No DEC_CRT2
   No DEC_CRT3        No DEC_CRT4        No DEC_CRT5        No Ansi_Color
   VMS Style Input    <CTRL-H> Backspace

I cannot remember which settings I tried and which I did not, but the
possible number of combinations is too big to try all.

If I run ssh from a terminal emulator in xorg, all seems fine.

Perhaps somebody can suggest an option to try or perhaps I'm missing
someting alltogeter?


More information about the freebsd-questions mailing list