phpMyAdmin httpd segmentation fault

Richard Simmonds richard at
Thu Feb 15 02:35:49 UTC 2007

I've just had the phpMyAdmin not starting problem after making changes to
php.ini and adding extensions. It began as a segmentation fault with only
phpMyAdmin and then progressed, as I fiddled with config for
php4-extensions, to breaking php entirely. I too have a modded make.conf
file which I am about to change in accordance with this tip. However, to get
phpMyAdmin working again, take a look at extensions.ini. I found there were
many duplicate lines, including some for extensions I thought I'd added and
then removed. I removed duplicates and moved to the
bottom of the list. Reboot and problem solved.

Hope this helps


Message: 13
Date: Wed, 14 Feb 2007 15:26:26 +0100
From: "Spil Oss" <spil.oss at>
Subject: Re: phpMyAdmin httpd segmentation fault
To: freebsd-questions at, "Terry Todd"
	<tlt at>
	<5fbf03c20702140626n66311addt1d6ccc3dc3de0c6f at>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed


Just solved my php / roundcube problems by removing -funroll-loops
from my CFLAGS in /etc/make.conf. Now I just have CFLAGS= -O2 -pipe

5.2.0   -march=pentium3m -O2 -pipe -funroll-loops       Fail
5.2.0   -march=pentium3 -O -pipe                       Success
5.2.1   -march=pentium3m -O2 -pipe -funroll-loops       Fail
5.2.1_1 -march=pentium3 -O -pipe                        Success
5.2.1   -march=pentium3m -O -pipe                       Success
enable eaccelerator                                     Success
enable suhosin                                          Success
5.2.1   -march=pentium3m -O2 -pipe                      Success
5.2.1   -march=pentium3m -O2 -pipe -funroll-loops       Fail
5.2.1_1 -march=pentium3m -O2 -pipe                      Success

So currently running apache-2.2.4 / php5-5.2.1_1 w/ suhosin /
eaccelerator 0.95

rouncube running fine, but phpMyAdmin still won't fly

Kind regards,


On 13/02/07, Gerard Seibert <gerard at> wrote:
> On Tuesday February 13, 2007 at 06:13:41 (AM) Terry Todd wrote:
> > I completed steps 1 through 6 that you suggested below.  Step 6 took
> > two whole days to complete.  I had to babysit the blue screens of
> >
> > Sorry to say it still does the exact same thing.  httpd seg faults
> > with no core file whenever the phpMyAdmin/index.php web page is browsed.
> Strange! It works perfectly here. Assuming you have nothing strange in
> your /etc/make.conf file, I am at a lose as to what the problem is.
> Sorry!
> --
> Gerard
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to
"freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list