Cannot get freebsd up and running...

Kevin Kinsey kdk at
Wed Feb 14 20:12:11 UTC 2007

Josh Makler wrote:
>    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"> 
> I  first posted this on a FreeBSD help forum, where I was quickly
 > redirected here (I guess this is a serious issue...)

Well, I don't wish to offend, but if that message was formatted anything 
like this one, probably nobody at that forum wished to deal with it. 
Like it or not, we don't know you personally, so you are going to be 
judged by the quality of your e-mail.   Your mailer seems pretty 
"b0rked", or else you were having a bit of a "one off" day, as most 
messages to the list don't look this bad.

Ah, perhaps you cut-n-pasted from the forum source?  Still not a great 
move.  All that aside ....

> I'm going to    first off my hardware is:
> AMD 3800+
> NviDia 7900 GT OC gfx card
> DVDRW/CDRW drive
> ??? Hard drive with windows XP on it (came with the PC...)
> SeaGate ST340810A Hard drive as slave (This one has FreeBSD on it)
> I added on to an EMachines T6536 to get this setup... I cannot find
> any info on my motherboard at all... I think its an American
> Megatrends board though.

OK - probably not "American Megatrends" -- they are a BIOS manufacturer.

EMachines have, in the last 3 or so years, begun to use motherboards 
that are modified for their needs; it may be hard to decide which board 
you have.  Have you tried a resource such as "Wim's BIOS" or 
"" or "" to get a *positive* ID on your board?

Almost everything you're discussing here depends on the motherboard.

> OK, this problem is not a simple one to diagnose, and probably near
 > impossible to fix.
> when I began to install FreeBSD (Actually PC-BSD, but it is 100% the
> same aside from the installer pretty much...) It gave me errors about
> ACPI (which my PC here does support...) I got through the installer by
> disabling ACPI, but it doesn't work that way when I try to start it
> up.
> these errors were:
> ACPI-0397: *** Error:    name:43005350
> ACPI-0397:    in namespace,    
 > ACPI-0204: *** Error: AcpiLoadTables: could not    AE_BAD_CHARACTER
> ACPI-0213: *** Error:    AE_BAD_CHARACTER
> ACPI: table    MADT: ACPI Startup failed with 
> the other errors are not so easy to describe. They move rapidly down
> the screen, and repeat over and over again until I pull the plug.
> these errors occur when I try to start the system after disabling

"disabling ACPI"  ??  How?  In the system's BIOS setup?  If FreeBSD 
doesn't like your ACPI table, you need to tell FreeBSD not to use ACPI.

>    these are for da0    all...)
>    all the info I    that they look somewhat like this,
>    although    messages:
>    SCSI    (da#: umass    Not Ready csi-0,aa,55,40
>    asc: 3a, 0
>    there is a 

Is there supposed to be more to this?

Note that "da0" refers generally to a SCSI drive, but could be some 
other device such as a USB drive, scanner, camera, etc.  Unplug 
everything from the computer and try the boot again; do you have the 
same error messages regarding "da0"?

> Windows works fine on this PC, and I had a working linux installation
> prviously as well (although I did get some funky errors too, but it
> just ignored then and moved on without trouble...) So I'm pretty sure
> it's some sort of issue BSD is having with my PC, and not some issue
> with my processor.
> please help, I'd really like to use BSD, and I'm willing to do
> whatever I can to work through this. I Don't mean to sound like a
> newbie, and I'm not, I've used other types of Unix for years, it's
> just this is my first *real* run in with BSD, and this is a pretty new
> computer I'm using... not to mention my first encounter with those
> errors.
> This    imply, even when    system.
> thanks in  

err, advance?

Is your system BIOS up-to-date?  It could be that a later BIOS version 
will enable your motherboard to talk turkey with the FBSD ACPI driver.

It's also quite possible that something about your motherboard causes 
FreeBSD to load the wrong ACPI table.  When booting, use the "escape to 
loader prompt" option, and try these commands:

 > set hint.acpi.0.disabled=1
 > boot

That may only get you running as in "example two" above; maybe try this 
the next time to get better error messages:

 > set hw.acpi.verbose
 > boot

You might also wish to try the following tunables in a similar manner, 
using "set" at the loader prompt and then "boot".


Lastly, there is a lot of hardware out there, and the FreeBSD Project 
doesn't have the resources to test the OS on every variation.  You might 
consider a different motherboard for this box.


Kevin Kinsey

You should make a point of trying every experience once -- except
incest and folk-dancing.
		-- A. Bax, Farewell My Youth

More information about the freebsd-questions mailing list