READ_DMA48 error interpretation

Richard Lynch ceo at
Wed Feb 7 21:59:00 UTC 2007

[I've tried to snip away a lot of stuff, without losing any context...]

On Tue, February 6, 2007 2:50 am, Ian Smith wrote:
> In freebsd-questions Digest, Vol 164, Issue 1
> At Message: 19
> On Mon, 5 Feb 2007 01:13:31 -0600 (CST) Richard Lynch <ceo at>
> wrote:
>  > On Tue, January 16, 2007 3:21 pm, Chuck Swiger wrote:
>  > > On Jan 16, 2007, at 1:13 PM, Richard Lynch wrote:

>  > ...
>  > >> +ad1: TIMEOUT - READ_DMA48 retrying (1 retry left) LBA=404955007
>  > >> +ad1: FAILURE - READ_DMA48 status=51<READY,DSC,ERROR>
>  > >> error=10<NID_NOT_FOUND>
>  > >> LBA=404955007
>  > >> +g_vfs_done():ad1s1[READ(offset=207336931328,
> length=16384)]error = 5
>  >

>  > > Try installing the sysutils/smartmontools port and run a drive
> self-

>  > I ran the short test on the problem drives, and it said everything
> was
>  > fine.
>  >
>  > I'll try the long test at a later date.
> Show us the result of 'smartctl -a <drive>' after a test or two.

>  > #2. Sequences like this show up a fair amount:
>  > Device: /dev/ad2, SMART Prefailure Attribute: 3 Spin_Up_Time
> changed
>  > from 152 to 153
>  > Device: /dev/ad2, SMART Prefailure Attribute: 3 Spin_Up_Time
> changed
>  > from 153 to 152
>  > Device: /dev/ad0, SMART Prefailure Attribute: 8
> Seek_Time_Performance
>  > changed from 251 to 250
> It'd be more useful to see these within the context shown by smartctl
> -a


I did miss that step, didn't I?


Here are all the smartctl -a outputs:

ad3 is giving the most errors...
ad1 gives a fair amount though
And the ad0 and ad2 seem to be giving the spinup errors.

ad0 is pretty much full
ad1 is the one I'm filling up currently
ad2 and ad3 have no actual content on them yet, but will "soon"

All the drives are kind of in an old PC tower (XT? AT???), except the
outer casing is, errr, not there...  Just the framework.

ad2 and ad3 are in one of these Thermaltake iCage things:
which converts the old-school floppy drive[s] bay into an IDE bay, and
puts a big honking fan blowing on them.

I'm not claiming it's "good enough" but I tried.

I left the iCage "bay" between them empty for airflow/cooling.

ad0 and ad1 are in the usual IDE bay of a tower.
I have a fan in there, but without the cover to shape the airflow,
perhaps that is not doing much useful...

I can touch the exposed front and back top (above IDE cable) and lay
my finger along it.  It's "hot" but not like, "ouch hot" :-)

I don't think it's 100C+ hot, as that's boiling -- but perhaps the
thermometer is somewhere inside or...

Seems more likely, though, that that number is Fahrenheit (sp?) and
not Celcius..

I didn't even realize it said C, and thought it was F...

Still seemed pretty dang hot to me.

I could haul in the outer casing and slap it on though, if needed.  I
think.  That big ol' fan might make that kinda hard.  Oh well.  I've
got tin-snips somewhere around here... :-v

>  > Oh, here's a rather long excerpt of the log in case there's minutae
>  > within it that I've failed to include:
>  >
> The output of smartctl -a for one or two of your drives would likely
> be
> much more indicative.  I don't claim to be an expert in this at all,
> but
> some of us might spot any obvious anomalies.

I sure appreciate the time y'all are taking on this!

I am definitely not a hardware guy, as you have probably already
surmised. :-)

Some people have a "gift" link here.
Know what I want?
I want you to buy a CD from some starving artist.
Yeah, I get a buck. So?

More information about the freebsd-questions mailing list