Boot Menu Damaged

E. J. Cerejo ecerejo at
Mon Dec 31 11:11:40 PST 2007

Jerry McAllister wrote:
> On Mon, Dec 31, 2007 at 10:46:04AM -0500, E. J. Cerejo wrote:
>> ----- Original Message ----- 
>> From: "Jerry McAllister" <jerrymc at>
>> To: "E. J. Cerejo" <ecerejo at>
>> Cc: <FreeBSD-questions at>
>> Sent: Monday, December 31, 2007 9:50 AM
>> Subject: Re: Boot Menu Damaged
>>> On Mon, Dec 31, 2007 at 01:17:51AM -0500, E. J. Cerejo wrote:
>>>> I'm running FreeBSD 6 stable and I lost my boot menu after reinstalling 
>>>> xp
>>>> and tried to fix it by booting with instalation cd and run "fdisk -B -b
>>>> /boot/boot0 /dev/ad0" it restored it but when I boot I get the mountroot>
>>>> prompt, it fails to mount ad0s2a, b, c, d.  Is it possible to fix this or
>>>> do I have to reinstall freebsd?
>>> It may be that you got the slices no longer marked as bootable.
>>> Try using fdisk(8) or boot0cfg(8) to re-enable booting on those slices.
>>> ////jerry
>> Do you run it from the instalation CD using fixit or run from the mountroot 
>> prompt on the computer.  It seems to me I can't can any commands from this 
>> prompt. 
> I would do it from the fixit.

Well that didn't work but I finally fixed it.

from the moutroot I was able to go into single user mode by running 
these commands:

fsck -p /
mount /

after this I was able to check and fix my /etc/fstab file, for some 
reason the mount points got all changed to slice 4, e.g. ad0s4a, changed 
them back to ad0s2a and so on, after that I was able to boot just fine.  
How it happened I have no idea.

More information about the freebsd-questions mailing list