mysql port problem

Sdävtaker sdavtaker at
Thu Dec 27 16:21:19 PST 2007

I'd installed the mysql51-server port (actual snapshot, FBSD6.2r)
After install I ran the create DBs scripts and tried to run a mysql 
client locally.
Tried to run the mysqld manually and got a Socket error.
/temp/mysql.sock is not....
I found the log file didnt log anything, so i started looking at the 
/var/db/mysql files...
All files in /var/db/mysql were in wheel group and root owner, so I did 
chown -R mysql mysql
chgrp -R mysql mysql
After that it started working, im using it and can do all my work, but...
Is it safe to set all those files to mysql user and mysql group?
Why the port create those files with root and wheel if they cant be 
accessed. I found lots of people trying to find out why mysql says "sock 
error" after installation.
I tried install mysql50-server and it has the same behavior and changing 
owner and group it is "solved" too.

Can someone enlight me?
Im running it from rc.conf with mysql_enable="YES"

More information about the freebsd-questions mailing list