lost X11 input from kybd-SOLVED!

Chuck Robey chuckr at chuckr.org
Thu Dec 27 15:14:39 PST 2007

Hash: SHA1

आशीष शुक्ल Ashish Shukla wrote:
> ,--[ On Thu, Dec 27, 2007 at 04:41:18PM -0500, chuckr wrote:
> | I'm running FreeBSD-current.  I updated about 30 hours ago, did a
> | rebuild of world and the kernel (without changing my kernel config file
> | at all.  I have to explain that I start my X11 via startx, I dislike
> | using anything like xdm (or kdm,gdm etc) so I always use startx, relying
> | on a ~/.xinitrc I have doctored nicely, to get me into kde.  Well, like
> | I normally do, I loeed in as root on ttyv0, my user "chuckr" on ttyv1,
> | and then did the startx as chuckr on ttyv1.  Everything started up fine,
> | but when I tried to kill an accientally started xterm, I found I
> | couldn't kill it with a control-D.  After a bit of experimentation, it
> | became obvious that I coulld get no keyboard input.  Thank god I can
> | still use the mouse perfectly, so I can kill X11 for troubleshooting via
> | the mouse fine.  After I did that, I found that all my keyboard input
> | which hadn't shown up on any xterm was pasted instead on the screen of
> | ttyv1, from which I'd started up X11 to begin with.
> | 
> | So, I can't get my keyboard input to go to X11.  I would REALLY love any
> | guesses at all about why this is, because I can';t use X now  on
> | FreeBSD, and that's my mailer.  I am using a poor replacement for this
> | now, so I would really like to know what's causinbg this ...
> | 
> | Oh, I have to add, I tried rolling the kernel back to kernel.old, no
> | differentce, it;s still bad.  I tried (after moving kernel.old back to
> | kernel) to download and install a new world and kernel.  Still fails
> | also.  I need some help here, badly.
> Very basic guess,  but does your xorg.conf is reconfigured recently,
> check for something like following  in xorg.conf:

Nice guess, but no, no changes in my xorg.conf file.  Doesn't amtter too
much, because I've solved the problem.

I recalled a change I made in my config file about 2 weeks ago.  I figued
it was too minor to count, so I completely forgot I even did it until I
wemt looking thru my kernel config with an eye towards hackery, then I
remembered that one line I'd added, to restrict the number of virtual
terminals to 8.  That's what used to be standard, way back when, but I
recently saw in the manual that the default's now 16.  I know that X
servers make use of the highest free terminal, and it COULD be possible
that someone coding that up decided not to check the number, just to reply
on a default ... now that the problem has disappeared (with only that one
change, so it's a certainty what fixed it), I have a bit of a suspicion
about that code now.

Ahh, heck, who cares.  Least it works.  Thanks for the effort.

> ---8<----8<----
> Section "ServerLayout"
>         Identifier     "single head configuration"
>         Screen      0  "Screen0" 0 0
>         InputDevice    "Keyboard0" "CoreKeyboard"
> EndSection
> Section "InputDevice"
>         Identifier  "Keyboard0"
>         Driver      "kbd"
>         Option      "XkbModel" "pc105"
>         Option      "XkbLayout" "us"
> EndSection
> --->8---->8----
> Anyways, have you tried 'xinit xterm', to see if X11 is receiving
> keyboard input, without KDE ? see, if there're any suspecting error
> messages, in your /var/log/Xorg.0.log

Version: GnuPG v2.0.4 (FreeBSD)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the freebsd-questions mailing list