FTPd INETd No Response But SFTP Works.

Rob Dalzell robert_d at usa.net
Thu Dec 27 14:12:11 PST 2007


I'm having trouble understanding why my FTPd is not responding.  I have
uncommented FTP in inetd.conf, inetd is enabled in rc.conf. There have been no
changes to the default setup of FreeBSD 6.2 AMD 64 other then the ports
install of php5 apache and mysql, so everything is set to basic security,
hosts.allow is untouched, and allowing all access.

I do have SSHD installed and I have been using SFTP up untill now.  I am
configuring a php script that attempts to update it's self using the PHP5-FTP
mod, but this php mod does not work correctly with SFTP, so I have tried to
enable the FTPd (Like I have in the past).  I cannot make a connection to the
FTP on port 21 with any FTP Client, just hangs.

I tried ports install of pure-ftp, as well, I could not connect to it either.

I can see them running in top, I can see inetd monitoring port 21 in sockstat,
but something just refuses to work.

Is there any known issue of having SFTP on port 22 and FTPd on 21 working

If anyone has a suggestion I'd appreciate any help.

More information about the freebsd-questions mailing list