lost X11 input from kybd

chuckr chuckr at chuckr.org
Thu Dec 27 13:41:03 PST 2007

I'm running FreeBSD-current.  I updated about 30 hours ago, did a
rebuild of world and the kernel (without changing my kernel config file
at all.  I have to explain that I start my X11 via startx, I dislike
using anything like xdm (or kdm,gdm etc) so I always use startx, relying
on a ~/.xinitrc I have doctored nicely, to get me into kde.  Well, like
I normally do, I loeed in as root on ttyv0, my user "chuckr" on ttyv1,
and then did the startx as chuckr on ttyv1.  Everything started up fine,
but when I tried to kill an accientally started xterm, I found I
couldn't kill it with a control-D.  After a bit of experimentation, it
became obvious that I coulld get no keyboard input.  Thank god I can
still use the mouse perfectly, so I can kill X11 for troubleshooting via
the mouse fine.  After I did that, I found that all my keyboard input
which hadn't shown up on any xterm was pasted instead on the screen of
ttyv1, from which I'd started up X11 to begin with.

So, I can't get my keyboard input to go to X11.  I would REALLY love any
guesses at all about why this is, because I can';t use X now  on
FreeBSD, and that's my mailer.  I am using a poor replacement for this
now, so I would really like to know what's causinbg this ...

Oh, I have to add, I tried rolling the kernel back to kernel.old, no
differentce, it;s still bad.  I tried (after moving kernel.old back to
kernel) to download and install a new world and kernel.  Still fails
also.  I need some help here, badly.


More information about the freebsd-questions mailing list