CDROM Boot Hangs But Only Under 6.x

David M. Patronis thenudnik at
Wed Dec 26 20:55:57 PST 2007

Tim Daneliuk wrote:
> illoai at wrote:
>> On 25/12/2007, Tim Daneliuk <tundra at> wrote:
>>> I am building a new server out of both older and brand new
>>> components.  It is based on a Pentium D 925 and ABIT LG-95Z
>>> mobo.  The DVD-RW is a Lite-On about a year old with very
>>> low hours on it.
>>> So ... here's a fun one:  I can boot and install FreeBSD 4.x (CD)
>>> or Novell SUSE Enterprise Linux Desktop 10 SP1 (DVD) via the
>>> DVD.  But attempting to do this with 6.x (I have tried 6.2R and
>>> 6.3-PRE disk #1) causes a hang during boot.  The loader gets
>>> as far as showing the vertical bar that ordinarily "spins"
>>> to show intitial kernel loading progress and the the machine
>>> just sits there.  There is some further activity on the optical
>>> drive at this point and then the cursor sort of jumps around a bit.
>>> I've not yet tried swapping the optical drive out - though I doubt
>>> this is the problem since I can load the other OSs.  I've tried
>>> removing and moving memory sticks in case this is a flakey
>>> memory problem - no change.  I've tried removing the only
>>> two cards in the machine: 3COM 905C-TX and an Adaptec 2940UW -
>>> no change.
>>> I have one last ditch thing I will try later tonight which is
>>> to force the DVD IDE port into PIO mode and out of DMA mode.
>>> But that's it.  I am stumped.  Ideas anyone?
>> If it is not hardware, check your bios settings (and mayhap
>> set back to default or very conservative) (of which the PIO
>> trick may work).
> I just swapped out the optical drive with a CD-RW - exact same
> symptoms.  Fiddling w/BIOS, seems to make no difference, though
> I am still poking at it.  I am utterly lost - never seen
> very standard hardware like this that FreeBSD could/would not
> boot and run on ...

Its probably an issue with the 6X series. I have experienced something 
similar and just spoke to someone via this list with a similar problem. 
In all cases thus far we were able to install using the 7X series.



More information about the freebsd-questions mailing list