usb/umass, devfs: this sucks

David Benfell benfell at
Wed Dec 26 13:00:03 PST 2007

On Wed, 26 Dec 2007 13:52:25 -0600, Paul Schmehl wrote:
> --On December 25, 2007 10:25:08 PM -0800 David Benfell 
> <benfell at> wrote:
> To the OP of this thread - generalized statements like this aren't very 
> helpful.  I have a USB  mouse and a USB keyboard, both of which work fine 
> and always have.  I mount USB thumb drives frequently to copy and move 
> files back and forth.  I have a USB hard drive that is automounted at boot.
Your thumb drives and hard drives are -- duh -- umass.  Okay, so the
original poster is even having problems with that.  I'll concede to an
over-generalization, but it is also rather frustrating when I--as an end
user--encounter problems with USB that I can't get any response on.

When I first posted about problems with my Treo, the suggestion was to
try upgrading to 7.0-BETA.  I've worked with CURRENT in the past, and have
generally had a positive experience, so I cheerfully complied, though I did
note that I was moving onto the bleeding edge.

I have had serious problems ever since and I will not repeat this mistake.
I initially had a little better luck with the Treo, but encountered the
"nasty IP bug" (and it was a doozy--I almost spent several hundred dollars
that I don't have on another router box from my ISP because all of a sudden
my system was both unreliable and my Internet access was unreliable).  I have
had to uninstall or disable pieces of software that, in one case, prevented
the system from coming all the way up, and in several cases, slowed the system
to less than a crawl.

And for all that, connectivity with the Treo is now non-existent, and I've
lost the functionality of my scanner.

Information on my system can be found at:


Inquiries to this list or to freebsd-current have generally yielded no response.

At least with 7.0-RC1, Xorg appears to be more stable.  (I noticed my port
upgrades rebuilding numerous gnome ports repeatedly.)

> None of these devices has ever given me problems.
> I'm not sure what you're referring to, but I suspect it's the "failure" to 
> automount devices without first doing some configuration or to mount 
> devices when you are not logged in as root.
The state of the documentation here leaves much to be desired.  In some
cases, information appears to be out of date, and in others, it is simply
wrong.  And before you complain that I should post reports of these problems,
see above about the response I get when I encounter problems.

Much as I love FreeBSD, and even with a background in computers going back to
the late 1970s (then as a programmer), the environment here does not seem to
foster a kind of interaction that solves problems.  Having been a programmer,
and having worked in customer service, I know that consumers are the most
frustrating people to deal with.  But we really need to be your friends.
Because that's how you make the product that we all love, better.

>> While I have not experienced difficulty with umass, I would have to
>> comment that as near as I can tell, *nothing* else on USB works.  Not my
>> scanner, nor my Treo.
>> Both have worked intermittently in the recent past, so I believe my
>> configuration is not at issue.
> These I can't comment on, because I don't use them, although I note that 
> there is a uscanner driver that *should* work for most scanners.  Man (4) 
> uscanner has a lenghty list of supported scanners.  You might check to see 
> if yours is on the list.
There is a conflict in the documentation here.  See the man pages for
sane, which specify that libusb should be used in place of the uscanner

David Benfell, LCP
benfell at
Resume available at
NOTE: I sign all messages with GnuPG (0DD1D1E3).
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list