Mounting Western Digital USB drive?

Drew Tomlinson drew at
Wed Dec 12 08:23:48 PST 2007

On 12/12/2007 8:20 AM Patrick Baldwin said the following:
> Drew Tomlinson wrote:
>> On 12/12/2007 7:50 AM Patrick Baldwin said the following:
>>> Trix Farrar wrote:
>>>> On Tue, Dec 11, 2007 at 06:03:03PM -0500, Patrick Baldwin wrote:
>>>>> Hi, I'm trying to mount a 160 GB Western Digital USB 2.0 drive on a
>>>>> FreeBSD 6.2 system.  This seemed like it should be relatively simple,
>>>>> but:
>>>>> webmail# mount /dev/da0s1 /mnt/usbdrive
>>>>> mount: /dev/da0s1 on /mnt/usbdrive: incorrect super block
>>>> It's probably formatted msdosfs.  Have you tried:
>>>> webmail# mount -t msdosfs /dev/da0s1 /mnt/usbdrive
>>> No, I hadn't, but that doesn't seem to work either:
>>> mount -t msdosfs /dev/da0s1 /mnt/usbdrive
>>> mount_msdosfs: /dev/da0s1: Invalid argument
>>> webmail# dmesg
>>> umass0: Western Digital External HDD, rev 2.00/1.04, addr 2
>>> da0 at umass-sim0 bus 0 target 0 lun 0
>>> da0: <WD 1600BEV External 1.04> Fixed Direct Access SCSI-4 device
>>> da0: 40.000MB/s transfers
>>> da0: 152627MB (312581808 512 byte sectors: 255H 63S/T 19457C)
>>> mountmsdosfs(): disk too big, sorry
>>> mountmsdosfs(): disk too big, sorry 
>> Just a guess here but it's likely the drive was formatted as NTFS 
>> instead of FAT-32 if it's a recent drive.  Try mount_ntfs.
>> HTH,
> Tried that, got:
> webmail# mount_ntfs /dev/da0s1 /mnt/usbdrive
> mount_ntfs: /dev/da0s1: Invalid argument
> Which doesn't make any sense to me, as it seems to
> be telling me the /dev/da0s1 is an invalid argument.
> Just for the hell of it, I tried:
> webmail# mount_ntfs /dev/da0 /mnt/usbdrive
> mount_ntfs: /dev/da0: Invalid argument
> Argh.  Hate it when what I expected to be a simple task
> eats this much time.

Another guess.  I wonder if you have to spell out the full slice such as 
/dev/da0s1<whatever>.  I know slice "c" is used to represent the entire 
drive but there's something special about it.  Thus verify that mounding 
/dev/da0/s1c will not destroy data before mounting.  Maybe bsdlabel 
would be of help here?  It should show you the slices on the drive and 
then you can try mounting.

Good luck,


Be a Great Magician!
Visit The Alchemist's Warehouse

More information about the freebsd-questions mailing list