jabberd will not start on reboot, only starts manually

Daniel Bye freebsd-questions at slightlystrange.org
Tue Dec 4 10:28:46 PST 2007

On Tue, Dec 04, 2007 at 06:06:00PM +0000, Pollywog wrote:
> On Tuesday 04 December 2007 15:11:32 Daniel Bye wrote:
> >
> > Try removing the # BEFORE: LOGIN line from the jabberd control script.
> > I haven't tested it, but from a cursory glance at the respective control
> > scripts, it feels like a sane first guess...
> What exactly does this do?  It worked.
> I first tried adding 'sleep 2' to the script as suggested in another reply.  I 
> thought that would work, but it did not.
> thanks to all who replied.

Check out the manual for rcorder(8), and look at the CAPITALISED files in

Essentially, LOGIN is a dummy service - it is used to control startup 
of services that should start late in the boot process. The jabberd control
script told rcorder(8) that it should run *before* the LOGIN service,
but the MySQL control script tells rcorder(8) that it wants to run
*after* the LOGIN service. So although you had REQUIRE: mysql in jabberd's
script, it was still getting run before MySQL. I guess. ;-)

You can determine what order things get run by doing

 # rcorder /etc/rc.d/* /usr/local/etc/rc.d/*

Anyway, glad it worked. You might want to get in touch with the jabberd
maintainer and see if he is willing to make the change permanent.


Daniel Bye
                                              ASCII ribbon campaign ( )
                                         - against HTML, vCards and  X
                                - proprietary attachments in e-mail / \
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20071204/a9664dd5/attachment.pgp

More information about the freebsd-questions mailing list