problem with dual disk/ dual boot installation

Joerg van den Hoff j.van_den_hoff at
Tue Dec 4 04:44:56 PST 2007


below  is  my  original question and the response I received
(I'm not yet subscribed to the list, so I found this only in
the  archive.  sorry for breaking the thread. If you care to
respond, please CC me directly).

> dear list,
> today  I've  tried  a  very first installation of 6.2 on the
> second  disk  of  an  i86  machine  which  runs  windows  xp
> professional 2002 service pack 2 on disk one.
> initially,  I  erroneously  did _not_ select installation of
> the boot manager on the first disk (were  windows  resides),
> but only on the second (the BSD one).
> after  the  intallation  was  completed without any apparent
> problems I noted my mistake (well, the machine  was  booting
> windows  ...)  

That setup sounds OK if you set the bios to boot the second drive,
instead of the first. 

The FreeBSD boot-manager is very basic, it can only boot a local
partition or chainload another drive, which is why you often need a
copy on each disk. In your case Windows will chainload directly, since
you have a standard MBR on the first drive. Your problem is that the
bios is not booting into the drive with manager on it. 

meanwhile  I  used  the `freesbie' liveCD and booted the machine 
into FreeBSD this way.

I then wrote the MBR with

fdisk -B -b /boot/boot0 ad0
fdisk -B -b /boot/boot0 ad1

to  both  disks.  as  far  as I understand the handbook this
seems the only thing necessary to allow correct operation of
the boot manager.

on  reboot (now, of course, without the liveCD...) I now see
the boot manager (which previously did'nt show up  at  all),
but the only available option is


i.e.  the  bootmanager  seems  not  to recognize the FreeBSD
installed on the second disk.  I  tried  the  same  (writing
boot0 to the MBR) with `boot0cfg' but to no avail.

I  can  mount  both  disks from within the `freesbie' booted
FreeBSD.  especially, the second disk (ad1) seems to contain
the  FreeBSD  installation as it should: the whole file tree
is there and 4 partitions (ad1s1a, ad1s1d,  ad1s1e,  ad1s1f)
are recognized/mounted.

what  am  I  doing  wrong?  how can I get the bootmanager to
recognize the second disk as FreeBSD-bootable?  if  I  can't
get  the  boot  manager  to  allow  selection  of  dos _and_
freebsd, is their a way to enforce exclusive boot  from  the
second disk (not that this would be an ideal solution:-))?

thanks in advance


More information about the freebsd-questions mailing list