java build error

Lowell Gilbert freebsd-questions-local at be-well.ilk.org
Thu Apr 26 15:23:59 UTC 2007


"RYAN M. vAN GINNEKEN" <luck at computerking.ca> writes:

> Hello all i am getting this error when trying to install java jdk15 from the ports. please help and thank you in advance 
>
> acpi0_check: nexus0 attachedom/sun/jmx/mbeanserver/MBeanInstantiatorImpl.java:162: warning: non-varargs call of varargsacpi0_check: legacy0 not-presentpe for last parameter; 
> cast to java.lang.Object for a varargs call acpi0_check: npx0 attached 
> cast to java.lang.Object[] for a non-varargs call and to suppress this warning acpi0_check: acpi0 attachednewInstance(null); 
> ^ 
> Note: * uses or overrides a deprecated API. 
> Note: Recompile with -Xlint:deprecation for details. 
> Note: Some input files use unchecked or unsafe operations. 
> Note: Recompile with -Xlint:unchecked for details. 
> 21 errors 
> 12 warnings 
> gmake[3]: *** [.compile.classlist] Error 1 
> gmake[3]: Leaving directory `/usr/ports/java/jdk15/work/j2se/make/java/java' 
> gmake[2]: *** [all] Error 1 
> gmake[2]: Leaving directory `/usr/ports/java/jdk15/work/j2se/make/java' 
> gmake[1]: *** [all] Error 1 
> gmake[1]: Leaving directory `/usr/ports/java/jdk15/work/j2se/make' 
> gmake: *** [j2se-build] Error 2 
> *** Error code 2 
>
> Stop in /usr/ports/java/jdk15. 
> *** Error code 1 

Not giving us much to work with, are you?  ;-)

Do you have a java compiler installed at that point?  Which one?

Are you using a non-supported version of FreeBSD with a recent ports tree?


More information about the freebsd-questions mailing list