Problem with Quotacheck after crash

Lowell Gilbert freebsd-questions-local at
Wed Apr 25 15:42:54 UTC 2007

"Don O'Neil" <lists at> writes:

> This question is related to my recent question about not being able to
> delete files after a disk crash... I solved that problem with the chflags
> (the no-delete flag was set!).. Thanks for all who suggested it.
> Now that I've deleted the files, I thought this problem would go away, but
> its not:
>  quotacheck: /home/quota.user: seek failed: Invalid argument
>         /dev/twed0s1d (/home)
> I've run an fsck on the volume from single user mode, after deleting the
> files, and it was clean, but I still get this error. I deleted the
> quota.user & files because they were corrupted when the crash
> happened. 
> I'm at a loss as to what to do next, any suggestions?

Run fsck again (with, as always, the filesystem not mounted) and keep
doing so until you get a run with no errors being corrected.  Don't
trust it if it tells you the filesystem is clean.

More information about the freebsd-questions mailing list