Port marked as broken

Ian Lord mailing-lists at msdi.ca
Tue Apr 24 17:57:06 UTC 2007



I just did a "cvsup" and a "pkg_version -v" to see that one of my port is


pecl-memcache-2.1.0                 <   needs updating (port has 2.1.2)


When I tried to "portupgrade -a" I got a message saying "pecl-memcache-2.1.2
is marked as broken: Configure fails."


I though something was broken on my system so I went to
/usr/ports/databases/pecl-memcache/ and did a "make deinstall" followed by a
"make clean" and a "make"


I get the same error message saying:

===>  pecl-memcache-2.1.2 is marked as broken: Configure fails.

*** Error code 1


Stop in /usr/ports/databases/pecl-memcache.




I did some research and found that tag "broken" is in the cvs so I guess the
developer set it that way.


2 questions:


1- How come a broken port is in the cvs ? Shouldn't the developer do a
rollback or something if something fails ?

2- Is there a way to reinstall an older version hoping to get the
functionality back (since I deinstalled :-()


Thanks a lot.



More information about the freebsd-questions mailing list