FW: IBM / FreeBSD - Install Update - Seems to be ACPI

Derek Ragona derek at computinginnovations.com
Thu Apr 19 10:37:12 UTC 2007

At 11:32 PM 4/18/2007, Murray Taylor wrote:

>In our initial posts, we stated that we seemed to be having issues
>getting the machine to boot with the 4 processors, so to bypass this we
>disabled ACPI on boot. This allowed us to get past the CPU error and
>continue to boot. However down the track we noticed things like the
>ethernet adapater not getting picked up, and the big problem - none of
>the disks getting recognised.
>We have since tried a few things, one of which was removing all but one
>of the CPU's. If we do this, and boot with ACPI enabled, all is totally
>fine. All disks are found, and I receive no CPU panic error.
>So it appears to me that by disabling ACPI in an attempt to bypass the
>QUAD CPU problem, we are causing another issue behind the scenes.
>The root of the problem now appears to be, that if we have anything over
>1 CPU, directly after the kernel is loaded (when booting from the CD),
>we receive the error message "panic: madt_probe_cpus_handler: CPU ID 38
>Too High". The moment a second CPU to the machine....it bombs out.

Have you tried booting a custom kernel with SMP enabled from the hard 
drives?  You might try that and install another CPU and see how the system 

Are these CPU's hyperthreaded too?  Or just single core CPU's?  I have had 
problems installing with some systems if hyperthreading was enabled.  Post 
installation with a custom SMP enabled kernel built I could turn 
hyperthreading on or off and the system booted and ran fine.


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.
MailScanner thanks transtec Computers for their support.

More information about the freebsd-questions mailing list