Working xorg.conf for Dell Latitude D820 laptop (NVidia Quadro NVS 120M GeForce Go 7400 512MB)?

Bill Moran wmoran at
Wed Apr 18 21:42:44 UTC 2007

In response to "Matt Kosht" <matt.kosht at>:

> On 4/12/07, Matt Kosht <matt.kosht at> wrote:
> > Does anyone have a working xorg.conf for this combo working with FreeBSD 6.2?
> >
> > Specifically I would like the onboard LCD on the laptop to display at
> > 1920x1200 and an attached external LCD at 1280x1024 both at 32 bit
> > color at the same time. I think this may be called twinview (?). This
> > configuration works fine in Windows XP so I know the hardware is
> > capable of it.
> >
> > I have searched for this quite a bit, but haven't found one that does
> > the 1920x1200 and the external display.  Many advanced thanks and free
> > virtual beers.
> >
> I have a semi-working configuration of xorg now running FBSD 6.2 on
> the Dell Latitude D820 (NVidia Quadro NVS 120M GeForce Go 7400 512MB).
> I am able to run the laptop's built in display at the correct
> resolution and 24 bit color (forget my mindless request for 32 bit
> color). I copied/modded a ubuntu xorg.conf that supposedly did
> everything I needed to get this far.
> Issue #1   I have an external LCD display (1280x1024) attached that I
> would like to use (when at my desk anyway) as a 2nd display (this
> works just ducky in Windows XP).  This still doesn't work and xorg
> doesn't seem to see make it available.
> Issue #2 I have installed/prodded/kicked the synaptics touchpad driver
> but it still doesn't work. It always comes up in dmesg as a glidepoint
> PS/2 mouse and xorg won't recognize it as anything but a PS/2 mouse
> which is unusable as the slightest touch sends the pointer sailing
> across the screen. I did manage to get an external USB mouse to work
> in the meantime but there's an minor issue with that as well (issue
> #3)
> Issue #3 the USB mouse when attached autostarts moused which makes it
> not work in X for some reason. If I kill moused it works just fine. I
> am have moused_enable=NO in /etc/rc.conf  so I am not sure why it
> autostarts this anyway.

This last one is the only one I know anything about.

If you configure X to use /dev/sysmouse, it will pick up on the device
that moused creates.  This may allow it to start working.  Along this
road may also lay a solution to #2, but I'm only guessing.

If you absolutely can't get moused to work, comment out the lines in
/etc/devd.conf that are causing it to autostart.

Bill Moran

More information about the freebsd-questions mailing list