Boot failure after installation

L Goodwin xrayv19 at
Thu Apr 12 19:37:39 UTC 2007

I have BOTH "ad0" (IDE HDD) AND "da0" (SCSI device #0). I posted detailed BIOS settings and install steps in previous emails. I've attached the BIOS and SCSI BIOS settings (with footnotes).

I have installed FreeBSD on da0 multiple times, each time creating a single slice/partition on da0, and setting da0 as bootable, and installing the FreeBSD boot manager on da0. OK?

I also found an IDE HDD yesterday, and installed Linux on ad0 (the IDE HDD), but am getting the exact same boot failure. 

I tried setting my bios to try booting from IDE drives first (before SCSI), and vice-versa (SCSI first, which is what it was set to), with no change.

I also tried removing the IDE HDD and booting, but boot from CD-ROM drive hangs, and boot from "C" fails.
I did not change BIOS settings re the (removed) IDE HDD. I've never worked on a machine that has both SCSI and IDE controller/drive configuration, and am not sure how to disentangle the IDE hard drive from the system without causing new problems. Ended up reinstalling the IDE HDD for now, but would like to remove it for use elsewhere (this machine has 5 SCSI drives, so don't need it).

Jerry McAllister <jerrymc at> wrote: 
> Will someone please explain in detail how to run the FreeBSD fdisk util 
> outside of the freebsd installer? Please provide detailed steps.

You just type   fdisk devname   where devname is the disk device.

There are a number of flags and parameters you may need to use.
Have you read the fdisk man page?    Also read the bsdlabel man page.

> What would the experts do next in this situation? I've checked and double-checked BIOS (current version is same as what I have -- 1013, so did not re-flash), SCSI BIOS (reset defaults and low-level formatted da0). I've performed "Minimal" FreeBSD install per step-by-step directions, and always says it's installed successfully, but can never boot from da0 (since repartitioning using FreeBSD "fdisk" util). I've verified that I'm creating a single partition (slice) on da0, making it the "active" partition, then setting it Bootable.

I would first ignore the issue of cylinders as has been mentioned.

> I booted the FreeSBIE LiveCD, and tried to mount da0:
>     mount /dev/da0 /mnt
>     mount: /dev/da0: Operation not permitted

First of all, do you even have a da0 drive?  Maybe it is  ad0

Second, is there a file system build on da0a?    I haven't seen anything
that indicates it.   You can only mount a file system.   Fdisk doesn't
have much to do with creating a file system.   That is newfs.

The standard way to build a disk is:
  Use fdisk to create slice[s] (1..4)  -- and possibly write an MBR on the disk.
  Use bsdlabel to divide the slice in to partitions (a..h) and possibly
      write a boot sector on the slice.
  Use newfs to create file systems on each of the partitions except swap & c.

Then you can mount any of those newfs created filesystems.  

You must first read the man pages for those utilities and also study the
relevant handbook sections.   Also, peruse the FreeBSD-questions archives.
I have written on this several time recently.   Find and read those.

Then, if you have further specific questions, come back and ask.  But, you
must do your homework first or our answers will be useless to you and a
waste of our time.


> Jerry McAllister  wrote: On Tue, Apr 10, 2007 at 07:48:07PM -0700, L Goodwin wrote:
> > Is there a way to run the "FDISK" tool outside of the freebds installer? 
> > How do I change the disk configuration without reinstalling freebsd 
> > every @#$%@#$% time?
> Yes, all sysinstall does is collect the information and run fdisk for you.
> See the man page   (enter  man fdisk )
> It can be a little hard to read at first.  The fdisk and bsdlabel don't 
> follow the normal man page form.
> One thing you must know;  you cannot run fdisk on a drive that is in
> active use.  If you booted from that drive or if you are CD-ed in to 
> a file system on the drive, the system will not let you write to the
> drive using fdisk.   You can only use fdisk to read the slice table
> and run prototype setups that do not actually write out to the disk.
> Trying to write to a drive that is active is a very popular mistake
> when attempting to use fdisk.
> So, read the fdisk man page and then come back with some more specific
> questions if you need.
> > I really want to set up a FreeBSD server and appreciate the learning experience, but it's way past the point where I should have switched to an OS that will actually run on my client's server. If I don't get it going tonight, I'm going to install the first Linux distribution that says "Hey, Sailor"...  =8-0
> Guess you will need to follow the installation instructions in the FreeBSD
> handbook more carefully.
> > BTW, I burned a freeSBIE 2.0.1 Live CD, but have no idea what to do with it. Yes, I am pathetically clueless. Thanks for your patience!
> Just boot it up and run it.    It will give you a very basic working
> environment.    Then do something like you might in a UNIX system, 
> like ls or cd or df or whatever.
> > 
> > Derek Ragona  wrote:   One other thing that 
> > might be happening is if the geometry of the drive isn't allowing an 
> > extended translation because of the age of your hardware, you may need to 
> > keep the boot partition, that is the entire boot partition (not talking 
> > slices here) within the first 1024 cylinders.  In the partition tool in 
> > sysinstall you can change the display to show different units, and one of 
> > those will be cylinders.  The 1024 cylinder limit is from older BIOS 
> > translations and if the boot partition extended beyond 1024 the system 
> > will give that same error you are getting.
> If the machine is built any less than about 11 years ago, this doesn't apply.
> >  With older hardware you may need to use multiple partitions instead of 
> > slices.  You can have 4 partitons on a drive (4 is hardcoded in the 
> > partition table size and a location) so you can add additional partitions 
> > for swap and /usr if you want.  Any partitions you use for filesystems 
> > like /usr the boot manager will see and offer to boot them.  They won't 
> > boot of course.  Swap partitions are ignored by the boot manager. 
> This is mostly incorrect and even backwards.
> First of all, there are 4 slices possible on a drive (or raid set for all
> that matters).   Microsoft tends to call slices "Primary Partitions".
> Slices are created and managed by the fdisk utility.  Fdisk also writes
> the Master Boot Record (MBR) (but not the boot sector).
> In FreeBSD you can divide each slice up in to partitions which are
> identified as a..h, although 'c' is reserved.   These partitions are
> created and managed by the FreeBSD bsdlabel utility (or disklabel in
> older versions).   Bsdlabel also writes the boot sector.
> >  Otherwise, I'd suspect it is a problem with the 6.2 you are using then.  
> > If you try with a boot within the 1024 (I wouldn't push that to the 
> > limit I'd say try like 950 cylinders) then I would try an earlier 
> > version such as 6.1 or 6.0.
> > 
> The whole issue of 1024 cylinders limit for bootable file systems
> went away with improved BIOS about 11 years ago.
> If you have a system old enough to have the problem, you should be
> updating the BIOS rather than trying to accomodate the limit.
> ////jerry
> >          -Derek
> >  
> > --  
> > This message has been scanned for viruses and 
> > dangerous content by MailScanner, and is 
> > believed to be clean. 
> > MailScanner thanks transtec Computers for their support. 
> > 
> >  
> > ---------------------------------
> > It's here! Your new message!
> > Get new email alerts with the free Yahoo! Toolbar.
> > _______________________________________________
> > freebsd-questions at mailing list
> >
> > To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"
> > 
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"
> ---------------------------------
>  Get your own web address.
>  Have a HUGE year through Yahoo! Small Business.

Expecting? Get great news right away with email Auto-Check.
Try the Yahoo! Mail Beta.
-------------- next part --------------

AWARD BIOS version 4.51PG

ASUS P2B-D ACPI BIOS rev 1013 (AWARD BIOS, single Pentium III/550) with onboard Adaptec 7890 SCSI BIOS:

	Boot Virus Protection: Disabled
	HDD Sequence SCSI/IDE First: SCSI


To access the SCSI BIOS, hold down CTRL+A when BIOS banner listing the driver name and the
attached devices appears: Does not work! Banner says "press F6 for SCSISelect..." (this works)

Adaptex Array1000 Family < SCSI Select(TM) > Utility

Array1000 Family at Bus:Channel 02:A

Would you like to configure the PIC device, or run theSCSI disk utilities? 
Select the option and press <Enter>.
Press <F5> to switch between color and monochrome modes.


Configure/View Host Adapter Settings
SCSI Disk Utilities

Arrow keys to move cursor, <Enter> to select option, <Esc> to exit (*=default)

Host Adapter Settings:

SCSI Bus Interface Definitions
	Host Adapter SCSI ID: 7
	SCSI Parity Checking: Enabled
	Host Adapter SCSI Termination: Press <Enter>
		Ultra2-LVD/SE Connector: Auto
		Fast/Ultra-SE Connector: Enabled

Additional Options
	SCSI Device Configuration: Press <Enter>
	  Settings for SCSI Device #0 (identical for #1-15):
		Initiate Sync Negotiation: yes
		Maximum Transfer Rate: 80.0
		Enable Disconnnection: yes
		Initiate Wide Negotiation: yes
		Send Start Unit Command: yes
		Include in BIOS Scan: yes
	Array1000 BIOS: Enabled
	BIOS Support for Bootable CD-ROM: Enabled

SCSI Disk Utilities:
Select SCSI Disk and press <Enter>

	SCSI ID #5:	ECRIX	VXA-1		Fast/Ultra-SE
	SCSI ID #6:	No device
	SCSI ID #7:	Array1000 Family
	SCSI ID #8:	No device
	SCSI ID #9:	No device
	SCSI ID #10:	No device
	SCSI ID #11:	No device
	SCSI ID #12:	No device
	SCSI ID #13:	No device
	SCSI ID #14:	No device
	SCSI ID #15:	No device

===================================== SCSI BIOS CHANGES: ====================================
4/9/2007: Changes made to resolve "DISK BOOT FAILURE" preventing FreeBSD 6.2 from loading.
1) SCSI BIOS: Reset to Host Adapter Defaults ("Reset ALL Options to Default Settings?").
2) Do low-level format on SCSI drive #0: DONE
3) Reinstall FreeBSD 6.2 on SCSI drive #0: 

More information about the freebsd-questions mailing list