Write_DMA48 Kernel Panic

Gary gary at mups.co.uk
Tue Apr 10 22:54:13 UTC 2007


When attempting to backup data to a new 500GB sata HDD I'm getting
a kernel panic, followed by reboot after the 15 second timeout.

I've tried the drive in my XP machine and formated/written to it fine,
I've also tried mounting the drive as a USB2 device via an external
enclosure in FreeBSD and again writes/reads are fine.

This is occuring on FreeBSD6-2 Release, Generic Kernel.

Part of the message reads:

   ad6 TIMEOUT - WriteDMA48 retrying (1 retry left)
   Fata trap 12: page fault while in kernel mode
   fault code: supervisor read, page not present
   instruction pointer: 0x20:0xc0685de4
   current process 6 (thread taskq)
   trap number = 12

I've attempted to lookup the function assosiated with the pointer
and obtained the following two entries

   c0685da0 t devclass_sysctl_handler
   c0685ddc t devclass_sysctl_init

In addition as the top error was DMA related, I've tried booting
without dma support with boot/loader.conf containing


With this in place the kernel panic doesn't occur, however instead
I get a load of

   g_vfs_done error=6


I'm currently backing up using the drive mounted in a USB2 enclosure
rather than connected via SATA and all appears well, so I'm pretty
sure the fault lies either with the SATA PCI Controller or somewhere
in the freeBSD code.

The specific controller card type is a

   SiI 3512 SATA150 controller

I'll try the controller card in another machine tomorrow just to
double check it's not actually a hardware fault. I have seen
a few other threads with similar errors to the above in a google
search, but as yet none of the suggested solutions worked.

Aside from that, anyone have any other ideas as to what could be
the cause or ideally how to resolve it?



More information about the freebsd-questions mailing list