mail and system-generated events

Frank Shute frank at
Tue Apr 10 21:01:03 UTC 2007

On Mon, Apr 09, 2007 at 04:37:15PM -0700, Kurt Buff wrote:
> Hate replying to myself, but I seem to have come up with a workaround.
> I hope it's actually a good fix.
> As part of my efforts earlier (deinstall and reinstall postfix) I also
> searched for and rm'ed all of the sendmail binaries I could find,
> before the reinstall.
> That broke it in a 'better' way, for some value of better:
>     atrun[1032]: exec failed for mail command: No such file or directory
> I went looking at my other FreeBSD boxes, and found this:
>     tophat# ll /usr/sbin/sendmail
>     lrwxrwxrwx  1 root  wheel  21 Nov 22  2005 /usr/sbin/sendmail ->
> /usr/sbin/mailwrapper
> This was missing on my problem system, so I put in the link per the
> above, and all now seems quite happy.
> Someone then pointed me at 'man mailwrapper'.
> Still doesn't tell me how I botched it, but it surely does tell me
> that I fixed it.
> Kurt

As well as mailwrapper(8) you want to have a look at mailer.conf(5)
where there is an example for postfix.

Also read this page:



echo "f r a n k @ e s p e r a n c e - l i n u x . c o . u k" | sed 's/ //g'

                      --->PGP keyID: 0x10BD6F4B<---                          

More information about the freebsd-questions mailing list