Adding interfaces to bridge0

Mario Lobo mario.lobo at
Tue Apr 10 18:18:59 UTC 2007


This is the situation:

Using FreeBSD 6.2-STABLE

I have benn using qemu to roll a windows XP machine, using a bridge to 
interface tap0 and rl0 on the same network my efault route board (xl0) is.

I was working great.  A few days ago , I updated src/sys (kernel - because of 
a java issue), recompiled & installed. Yesterday I needed to rum XP. I 
started qemu and  windows started fine, the netword "hardware" came in fine 
but I had no connectivity ate all. I pinged out from windows but tcpdump 
would only report packets from tap0.

I tried recompiling qemu/kqemu but no change.

I closed qemu and tried to set up the bridge manually. That's when I found 

kldload if_bridge

ifconfig bridge0 create

ifconfig bridge0 addm rl0 addm tap0 up

ifconfig: BRDGADD rl0: Invalid argument
ifconfig: BRDGADD tap0: Invalid argument

I have 3 network boards on my machine and this happens when I try to add any 
of them.

Could this be due to kernel out-of-sync with userland?
something else?

   //| //|         Mario Lobo
  // |// |
 //  //  |||||||  FreeBSD since 2.2.8 - 100% Rwindows-free

More information about the freebsd-questions mailing list