Gary gary at
Tue Apr 10 17:40:23 UTC 2007

On Tue, 10 Apr 2007 18:08:53 +0100, Gary <gary at> wrote:

> Hi,
> I've got a SiI 3512 SATALink PCI Controller card plugged into my
> PC running FreeBSD6.2 Release Generic kernel. On bootup dmesg
> shows
> uhub2: 4 ports with 4 removable, self powered
> atapci0: <SiI 3512 SATA150 controller> port  
> 0xbc00-0xbc07,0xb800-0xb803,0xb400-0xb407,0xb000-0xb003,0xbe00-0xbe0f  
> mem 0xefeffe00-0xefefffff irq 11 at device 3.0 on pci2
> ata2: <ATA channel 0> on atapci0
> ata3: <ATA channel 1> on atapci0

Looks like I'm going to be answering my own post

Just tried the sata drive plugged direct into one of the two internal
ports the PCI card exposes (as opposed to one of the two it exposes
outside the case) and the drive detects/works fine.

I've attached a eSATA breakout cable to this internal connector
on the PCI card and the drive now also detects and works from
within the external eSATA/USB2 enclosure.

Probably have to jumper the PCI card to get the external ports working
rather than internal and I didn't notice.

Anyhow, problem solved, typically straight after spending a few hours
getting no where, posting a help message and then realising

Thought I'd post the solution just in case anyone else has a similar




More information about the freebsd-questions mailing list